Skip to content

Commit

Permalink
app-text/enchant: Fix hunspell 1.5 support (#600952 by Lars Wendler)
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
pacho2 committed Nov 27, 2016
1 parent 0998e89 commit cef3d32
Show file tree
Hide file tree
Showing 2 changed files with 24 additions and 10 deletions.
22 changes: 12 additions & 10 deletions app-text/enchant/enchant-1.6.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@
# $Id$

EAPI=6

inherit eutils autotools

DESCRIPTION="Spellchecker wrapping library"
Expand All @@ -13,33 +12,37 @@ SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"

IUSE="aspell +hunspell static-libs zemberek"
REQUIRED_USE="|| ( hunspell aspell zemberek )"

COMMON_DEPENDS="
dev-libs/glib:2
aspell? ( app-text/aspell )
hunspell? ( >=app-text/hunspell-1.2.1:0= )
zemberek? ( dev-libs/dbus-glib )"

zemberek? ( dev-libs/dbus-glib )
"
RDEPEND="${COMMON_DEPENDS}
zemberek? ( app-text/zemberek-server )"

zemberek? ( app-text/zemberek-server )
"
DEPEND="${COMMON_DEPENDS}
virtual/pkgconfig"

REQUIRED_USE="|| ( hunspell aspell zemberek )"
virtual/pkgconfig
"

DOCS="AUTHORS BUGS ChangeLog HACKING MAINTAINERS NEWS README TODO"

PATCHES=(
# http://bugzilla.abisource.com/show_bug.cgi?id=13772
"${FILESDIR}/${P}-hunspell140_fix.patch"
"${FILESDIR}/${P}-hunspell150_fix.patch"
)

src_prepare() {
default
sed -i \
-e 's:noinst_PROGRAMS:check_PROGRAMS:' \
tests/Makefile.am || die
mv configure.in configure.ac || die
AT_M4DIR=ac-helpers eautoreconf
}

Expand All @@ -56,6 +59,5 @@ src_configure() {

src_install() {
default

prune_libtool_files --all
prune_libtool_files --modules
}
12 changes: 12 additions & 0 deletions app-text/enchant/files/enchant-1.6.0-hunspell150_fix.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
diff -upr enchant-1.6.0.orig/src/myspell/myspell_checker.cpp enchant-1.6.0/src/myspell/myspell_checker.cpp
--- enchant-1.6.0.orig/src/myspell/myspell_checker.cpp 2016-11-26 16:04:05.689051339 +0200
+++ enchant-1.6.0/src/myspell/myspell_checker.cpp 2016-11-26 16:05:11.380014568 +0200
@@ -431,7 +431,7 @@ MySpellChecker::requestDictionary(const
if(myspell == NULL){
return false;
}
- char *enc = myspell->get_dic_encoding();
+ const char *enc = myspell->get_dic_encoding();

m_translate_in = g_iconv_open(enc, "UTF-8");
m_translate_out = g_iconv_open("UTF-8", enc);

0 comments on commit cef3d32

Please sign in to comment.