Skip to content

Commit

Permalink
sys-apps/dtc: avoid using environment for make options
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: Sergei Trofimovich <[email protected]>
  • Loading branch information
Sergei Trofimovich committed Jul 7, 2020
1 parent 6c5f0ce commit cf3b25e
Show file tree
Hide file tree
Showing 2 changed files with 114 additions and 6 deletions.
86 changes: 86 additions & 0 deletions sys-apps/dtc/dtc-1.5.0-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,86 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit multilib toolchain-funcs eutils

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/dtc/dtc.git"
inherit git-r3
else
SRC_URI="https://www.kernel.org/pub/software/utils/${PN}/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi

DESCRIPTION="Open Firmware device tree compiler"
HOMEPAGE="https://devicetree.org/ https://git.kernel.org/cgit/utils/dtc/dtc.git/"

LICENSE="GPL-2"
SLOT="0"
IUSE="static-libs yaml"

BDEPEND="
sys-devel/bison
sys-devel/flex
virtual/pkgconfig
"
RDEPEND="yaml? ( dev-libs/libyaml )"
DEPEND="${RDEPEND}"

DOCS="
Documentation/dt-object-internal.txt
Documentation/dts-format.txt
Documentation/manual.txt
"

PATCHES=(
"${FILESDIR}"/${PN}-1.4.4-posix-shell.patch
"${FILESDIR}"/${PN}-1.5.0-fdt_check_full-visibility.patch
"${FILESDIR}"/${PN}-1.5.0-gcc-10.patch
)

_emake() {
# valgrind is used only in 'make checkm'
emake \
NO_YAML=$(usex !yaml 1 0) \
NO_VALGRIND=1 \
\
AR="$(tc-getAR)" \
CC="$(tc-getCC)" \
PKG_CONFIG="$(tc-getPKG_CONFIG)" \
\
V=1 \
\
PREFIX="${EPREFIX}/usr" \
\
LIBDIR="\$(PREFIX)/$(get_libdir)" \
\
"$@"
}

src_prepare() {
default

sed -i \
-e '/^CFLAGS =/s:=:+=:' \
-e '/^CPPFLAGS =/s:=:+=:' \
-e 's:-Werror::' \
-e 's:-g -Os::' \
Makefile || die

tc-export AR CC PKG_CONFIG
}

src_compile() {
_emake
}

src_test() {
_emake check
}

src_install() {
_emake DESTDIR="${D}" install

use static-libs || find "${ED}" -name '*.a' -delete
}
34 changes: 28 additions & 6 deletions sys-apps/dtc/dtc-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -37,6 +37,25 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.4.4-posix-shell.patch
)

_emake() {
# valgrind is used only in 'make checkm'
emake \
NO_YAML=$(usex !yaml 1 0) \
NO_VALGRIND=1 \
\
AR="$(tc-getAR)" \
CC="$(tc-getCC)" \
PKG_CONFIG="$(tc-getPKG_CONFIG)" \
\
V=1 \
\
PREFIX="${EPREFIX}/usr" \
\
LIBDIR="\$(PREFIX)/$(get_libdir)" \
\
"$@"
}

src_prepare() {
default

Expand All @@ -45,18 +64,21 @@ src_prepare() {
-e '/^CPPFLAGS =/s:=:+=:' \
-e 's:-Werror::' \
-e 's:-g -Os::' \
-e "/^PREFIX =/s:=.*:= ${EPREFIX}/usr:" \
-e "/^LIBDIR =/s:=.*:= \$(PREFIX)/$(get_libdir):" \
Makefile || die

tc-export AR CC PKG_CONFIG
export V=1
export NO_YAML=$(usex !yaml 1 0)
export NO_VALGRIND=1 # used only in 'make checkm'
}

src_compile() {
_emake
}

src_test() {
_emake check
}

src_install() {
default
_emake DESTDIR="${D}" install

use static-libs || find "${ED}" -name '*.a' -delete
}

0 comments on commit cf3b25e

Please sign in to comment.