forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-emacs/ebuild-mode: Version bump.
This introduces a new "glep-mode" major mode for editing of reStructuredText GLEPs. Package-Manager: Portage-2.3.11, Repoman-2.3.3
- Loading branch information
Showing
3 changed files
with
39 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST ebuild-mode-1.37.tar.xz 30816 SHA256 f7368a8757036874dde542c69c26b824fe3da5241098f89a6b7d7e2665cbbf1d SHA512 1d570b213ad0c6eef8817f69c99c0862703b9bddc24477234dde542b697ba372a06bbe8e4a91179a7d528b720a7dbfc13bb92c8ea0a4d3b3b8684fa4ee0065c0 WHIRLPOOL 75928f5965bdfe66733e203588f01ab3b5de67a5958d33f41069d0793842bd9617ab0904ab71f95aeae04e0aa2f55646e4c545d6199cc1d357140b8fd1a714ab | ||
DIST ebuild-mode-1.38.tar.xz 30744 SHA256 63f39bb1a09e29b86e5048f162f4779f287c8825e161a092e74530962947d3c3 SHA512 bfcc4fb100f7d9299e9b466c7661e865f9b93ee352780da1647f1a98159fe3e9eeb8cd4b7d1d9906d532316d1256ec7b6f821cac3d064cda15f2fd62ca7cb349 WHIRLPOOL ea61825ac0fd2d50ec9722088b03ed9664708dd6fac076ff3db8323bfdf8d1b2e351c7059f2f77471ea200b7a19d9f67ab233ebdb743ece80218f0e940fb0706 | ||
DIST ebuild-mode-1.39.tar.xz 34476 SHA256 15ed940d9cc600a9058ced8dcee0e88e0cd635cfe85c385e84a4b738ed70e051 SHA512 ba4f082c5b9bf8e80077f31d8134eb06d927d1f34b505a43b093832b3763a84f37136f8458d863b28d31c0512ffa7c460c1f7640f2e107f3eec3f5c95eb80da7 WHIRLPOOL ae2c4cf6783adb1dad058a84794efdd510d972a81961da21adeaf5f36cc9870ecfa80c1aa1ae8fe79e2c10c8082f9f6dc32e6e051f846dce1787843e9f0e78f5 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit readme.gentoo-r1 elisp | ||
|
||
DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files" | ||
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs" | ||
SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz" | ||
|
||
LICENSE="GPL-2+ GPL-3" # GPL-3 (only) for glep-mode.el | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos" | ||
|
||
DEPEND="sys-apps/texinfo" | ||
|
||
DOCS="ChangeLog keyword-generation.sh" | ||
ELISP_TEXINFO="${PN}.texi" | ||
SITEFILE="50${PN}-gentoo-1.39.el" | ||
DOC_CONTENTS="Some optional features may require installation of additional | ||
packages, like app-portage/gentoolkit-dev for echangelog." |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,16 @@ | ||
(add-to-list 'load-path "@SITELISP@") | ||
(autoload 'ebuild-mode "ebuild-mode" | ||
"Major mode for Portage .ebuild and .eclass files." t) | ||
(autoload 'gentoo-newsitem-mode "gentoo-newsitem-mode" | ||
"Major mode for Gentoo GLEP 42 news items." t) | ||
(autoload 'glep-mode "glep-mode" | ||
"Major mode for Gentoo Linux Enhancement Proposals." t) | ||
|
||
(add-to-list 'auto-mode-alist '("\\.\\(ebuild\\|eclass\\)\\'" . ebuild-mode)) | ||
(add-to-list 'auto-mode-alist | ||
'("/[0-9]\\{4\\}-[01][0-9]-[0-3][0-9]-.+\\.[a-z]\\{2\\}\\.txt\\'" | ||
. gentoo-newsitem-mode)) | ||
(add-to-list 'auto-mode-alist '("/glep.*\\.rst\\'" . glep-mode)) | ||
(add-to-list 'interpreter-mode-alist '("openrc-run" . sh-mode)) | ||
(add-to-list 'interpreter-mode-alist '("runscript" . sh-mode)) | ||
(modify-coding-system-alist 'file "\\.\\(ebuild\\|eclass\\)\\'" 'utf-8) |