Skip to content

Commit

Permalink
app-emulation/docker-runc: Add snapshot for docker-17.03.x
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.4, Repoman-2.3.2
  • Loading branch information
mrueg committed Mar 6, 2017
1 parent ff8800b commit cf78c37
Show file tree
Hide file tree
Showing 2 changed files with 60 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/docker-runc/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST docker-runc-1.0.0_rc2_p20170201.tar.gz 560793 SHA256 11f69923a786efb82b65d9f1eec0ac665a985e631a67f3f4d466dac720efacdd SHA512 8c19a02a55108cef36cbd1ff739a3c8e2962d188c426517fce91483ec525546d39c14072f0a0f2471b6b70a05cf6c1f0e99cfeb5e87203fcbae955bd5f5bd16b WHIRLPOOL 8a1f44234c668aca5c53e401ce80e2c297ad9c7ed0b10d782494e93020f824e6d5e3a00be221f1ff5d039df998c43556228503788181a45256d91278dd005721
DIST docker-runc-1.0.0_rc2_p20170222.tar.gz 560798 SHA256 ab7913b8062f77c0a2b16ae335d74eb78aa85e8d4dcccbf0793b14caf1a3f0b2 SHA512 1ea7ed8a98b2cbc508933608d7dc16b26c1507021200691e66fa61d4c567a5437aafae8b9710bf29ba94a8c4853de7f9e38e9e09de9a358a68e0e431771a13cc WHIRLPOOL e198528c956de5921ac5fa4395d0391d4b94413b46d82596bc47c525365e80b3b839df07b7f63642ad7d9c6f078c265f6e0d16397dba086c152e50ee0ebdb7be
59 changes: 59 additions & 0 deletions app-emulation/docker-runc/docker-runc-1.0.0_rc2_p20170222.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EGO_PN="github.com/docker/${PN/docker-}"

if [[ ${PV} == *9999 ]]; then
inherit golang-vcs
else
MY_PV="${PV/_/-}"
EGIT_COMMIT="a01dafd48bc1c7cc12bdb01206f9fea7dd6feb70"
RUNC_COMMIT="a01daf" # Change this when you update the ebuild
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~ppc64"
inherit golang-vcs-snapshot
fi

DESCRIPTION="runc container cli tools (docker fork)"
HOMEPAGE="http://runc.io"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="apparmor hardened +seccomp"

RDEPEND="
apparmor? ( sys-libs/libapparmor )
seccomp? ( sys-libs/libseccomp )
!app-emulation/runc
"

S=${WORKDIR}/${P}/src/${EGO_PN}

RESTRICT="test"

src_compile() {
# Taken from app-emulation/docker-1.7.0-r1
export CGO_CFLAGS="-I${ROOT}/usr/include"
export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
-L${ROOT}/usr/$(get_libdir)"

# Setup GOPATH so things build
rm -rf .gopath
mkdir -p .gopath/src/"$(dirname "${GITHUB_URI}")"
ln -sf ../../../.. .gopath/src/"${GITHUB_URI}"
export GOPATH="${PWD}/.gopath:${PWD}/vendor"

# build up optional flags
local options=(
$(usex apparmor 'apparmor')
$(usex seccomp 'seccomp')
)

emake BUILDTAGS="${options[*]}" \
COMMIT="${RUNC_COMMIT}"
}

src_install() {
dobin runc
}

0 comments on commit cf78c37

Please sign in to comment.