Skip to content

Commit

Permalink
app-portage/iwdevtools: add 0.9.0
Browse files Browse the repository at this point in the history
Very minor release, mostly just for non-linux prefix support.

Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
ionenwks committed Jan 19, 2022
1 parent 854110b commit cfac745
Show file tree
Hide file tree
Showing 2 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-portage/iwdevtools/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST iwdevtools-0.8.1.tar.gz 58058 BLAKE2B b9f17f68bb073ecf2d8a94fc8b97d95f7188e7526dd6a32cf33aa3b01fe82bf25c696cc2be9cbdc0aaa3a8279532e506ab287d3e25da5d5fb55789064d47aec6 SHA512 cb365e7010d620f2a255db0244ee1a38fd5714a17093b2e2a71627155764165853f99a4477b281b92061f7fe184297a222a8c79c2c62beb8e0656761feee859b
DIST iwdevtools-0.9.0.tar.gz 58476 BLAKE2B c036e151f76578633522f32665b30a2521131c265b5815934feffe2d3028e1e7fea314b2b41a719683b9ecc43f31f4aa7ffc10fe159dc62870bf43dc1da750bd SHA512 7d433d537d7b7ea3954e224be52dcd3a5fcb6be9b9f532096955b778a98d8a8a04e0c03f53615d01603a298859fe2129b3f3b126a671a1e202f08718bb15f104
68 changes: 68 additions & 0 deletions app-portage/iwdevtools/iwdevtools-0.9.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit meson optfeature

DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
HOMEPAGE="https://github.com/ionenwks/iwdevtools"
SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
app-misc/pax-utils
app-portage/portage-utils
sys-apps/diffutils
sys-apps/file
sys-apps/portage
|| ( sys-apps/util-linux app-misc/getopt )"
BDEPEND="
sys-apps/help2man
|| ( sys-apps/util-linux app-misc/getopt )
test? ( ${RDEPEND} )"

src_configure() {
local emesonargs=(
-Ddocdir=${PF}
-Deprefix="${EPREFIX}"
-Dshellcheck=false
$(meson_use test)
)

has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )

meson_src_configure
}

pkg_postinst() {
optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail

if [[ ! ${REPLACING_VERSIONS} ]]; then
elog "Optional portage integration relies on using /etc/portage/bashrc."
elog "The example bashrc can be used as-is if not already using one:"
elog
elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
elog
elog "Otherwise, inspect the tools' --help output and the example to integrate"
elog "(if not defining the same phase functions, the example can be sourced)."
elog
elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
elog
elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
elog
elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
fi

if [[ ${REPLACING_VERSIONS} ]] &&
ver_test ${REPLACING_VERSIONS} -le 0.7.0; then
elog "qa-* bashrcs now use \`eqawarn\` for portage output. If no longer"
elog "seeing messages post-emerge, ensure 'qa' is in PORTAGE_ELOG_CLASSES."
fi
}

0 comments on commit cfac745

Please sign in to comment.