Skip to content

Commit

Permalink
dev-lua/busted: initial commit
Browse files Browse the repository at this point in the history
  • Loading branch information
williamh committed Nov 11, 2015
1 parent ba3d52d commit cfcd3ac
Show file tree
Hide file tree
Showing 3 changed files with 61 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lua/busted/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST busted-2.0_rc11_p0.tar.gz 48368 SHA256 115af425543354ad20cb0502a93b87e902df391d8d49cec357852ed65072521a SHA512 f09cd5ad2be05b37254e9d602433639340b020e0670e8a435f1ee1d312eced37e284c2f5a398d7a0403fac0023851b74dbe659373e495c5354f48baed814c4b8 WHIRLPOOL 681603c92a91278c4f8bc462f6330d21ff2a0a7e867058819daf8dc81fc6540d577ccc1152c3696265f22fec744c0f28fa42a47a31134024b54e3598a3ce2291
44 changes: 44 additions & 0 deletions dev-lua/busted/busted-2.0_rc11_p0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit toolchain-funcs

# The below is the upstream version number. The -x suffix should be kept
# in sync with the _px suffix in the ebuild version.
MY_PV="2.0.rc11-0"

DESCRIPTION="Elegant Lua unit testing"
HOMEPAGE="http://olivinelabs.com/busted/"
SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""

COMMON_DEPEND=">=dev-lang/lua-5.1:="
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig"
RDEPEND="${COMMON_DEPEND}
~dev-lua/lua_cliargs-2.5_p5
>=dev-lua/luafilesystem-1.5.0
>=dev-lua/dkjson-2.1.0
>=dev-lua/say-1.3
>=dev-lua/luassert-1.7.8
>=dev-lua/lua-term-0.1_p1
>=dev-lua/penlight-1.3.2
>=dev-lua/mediator_lua-1.1.1_p0
>=dev-lua/luasocket-2.0.1
"

S="${WORKDIR}/${PN}-${MY_PV}"

src_install() {
dobin bin/busted
insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"/${PN}
doins -r busted/*
dodoc *.md
}
16 changes: 16 additions & 0 deletions dev-lua/busted/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
<email>[email protected]</email>
<name>William Hubbs</name>
</maintainer>
<longdescription lang="en">
An elegant, extensible, testing framework.
Ships with a large amount of useful asserts,
plus the ability to write your own. Output
in pretty or plain terminal format, JSON,
or TAP for CI integration. Great for TDD
and unit, integration, and functional tests.
</longdescription>
</pkgmetadata>

0 comments on commit cfcd3ac

Please sign in to comment.