Skip to content

Commit

Permalink
dev-ros/sound_play: fix build without FEATURES=test, bug #567466
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
Signed-off-by: Alexis Ballier <[email protected]>
  • Loading branch information
aballier committed Dec 4, 2015
1 parent 77a73ec commit cfd4ead
Show file tree
Hide file tree
Showing 2 changed files with 27 additions and 0 deletions.
26 changes: 26 additions & 0 deletions dev-ros/sound_play/files/test.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
commit ecdde483c81fb89e35f025ee3aacba7cd45528ab
Author: Alexis Ballier <[email protected]>
Date: Fri Dec 4 12:38:42 2015 +0100

sound_play: Fix build with -DCATKIN_ENABLE_TESTING=OFF.

https://bugs.gentoo.org/show_bug.cgi?id=567466

diff --git a/sound_play/CMakeLists.txt b/sound_play/CMakeLists.txt
index ada0b07..3f9604c 100644
--- a/sound_play/CMakeLists.txt
+++ b/sound_play/CMakeLists.txt
@@ -16,9 +16,11 @@ generate_messages(DEPENDENCIES actionlib_msgs)
catkin_package(CATKIN_DEPENDS message_runtime actionlib_msgs
INCLUDE_DIRS include)

-catkin_add_nosetests(scripts/test)
+if(CATKIN_ENABLE_TESTING)
+ catkin_add_nosetests(scripts/test)

-add_subdirectory(test)
+ add_subdirectory(test)
+endif()

install(PROGRAMS
scripts/playbuiltin.py
1 change: 1 addition & 0 deletions dev-ros/sound_play/sound_play-0.2.9.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -33,3 +33,4 @@ RDEPEND="${RDEPEND}
media-libs/gst-plugins-good:0.10
media-libs/gst-plugins-base:0.10
"
PATCHES=( "${FILESDIR}/test.patch" )

0 comments on commit cfd4ead

Please sign in to comment.