Skip to content

Commit

Permalink
dev-python/expects: add version 0.8.0_rc5
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
Alex Brandt committed May 15, 2016
1 parent 8c1a003 commit cfde437
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/expects/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST expects-0.4.2.tar.gz 23813 SHA256 b1e0b27141f784fe81a143153f23d3c8220fe8ec1
DIST expects-0.8.0_rc2.tar.gz 27307 SHA256 c7959a0b0f76a186b1d3687fbdedaf551f8bbbddbd66e5307c3a52c787a779de SHA512 6ae4553838ce4d27993772cec33f1e1a18d539af4a9b0f62f66ef1fb78464a46f5b76a420096d2d36881f4dc581b69e8f6c8783b89d794df753fdffab275cc33 WHIRLPOOL 04a04534571e8a15bcc2e1d7a9fc2b63bb772a8adaaf0b6239d375f1e5f750be7d7fa9fd10f5d84f017c4e3ad6274a7955e5b70928ee6eec7c199181169e5741
DIST expects-0.8.0_rc3.tar.gz 27478 SHA256 a2809c6c51cf18b3316102f21e9d14d195edfd34526cfcad7d959d592deacbd4 SHA512 2566ddfcb83bb3d58dbddcc881f2b743cca061057f77a52da49d3eb6c16dc1fafaca900734d7023550c85dfd0b86d433a9328daf5a989ab91757d83e9eaa4d81 WHIRLPOOL 7e6c81a27c2dd01d261731db6deefe0830515731dc485278bbf2d5de84a726cef7cea2a5ecd514ccda169167f7cb0ca32f7b02de95c6bdcbd23f26faf502b87d
DIST expects-0.8.0_rc4.tar.gz 27586 SHA256 3a4f4a5ae2ebd15b387eda0a841a3d61c9ac7c4171263a247776a7bd5f3135e1 SHA512 5c9fa6c9b296aba2a3a907e6e7b49bbb371a3deb0e8eca34a9df51f909dbb5e5700ec9c26a78205e6131c8154b75bb2381cab1b7fcb227edbb103b4c3f5784a5 WHIRLPOOL c9d78385c67ec7cb441159fc223ffc6eb3df14ed4330f17e064eb14ce17fb1201952581007a8f8da31dd1e4c8bb18baccb501345b8dca12eb914c198c1184861
DIST expects-0.8.0_rc5.tar.gz 27814 SHA256 49c0c6c82286e74dbe5e101a86926e4a1d5e11df582f9b7ab2953fa02d3e8e35 SHA512 f423327fdc16b6c74cd096b2d0b521224386793e43f36f8a75202876be4eae247c6193e272eb51e8d07c6169051ffdf18b8b28b3104e307c4cf27420b2a4f700 WHIRLPOOL f4cc56404e3eaf458dd4f2f0545463f5c8e218399ace65b0ab64982d9d10db4f93f20df1a4275a9271da594cd1dc7be8fabb6602b7c7b364ecbecdbef772fd9a
40 changes: 40 additions & 0 deletions dev-python/expects/expects-0.8.0_rc5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python2_7 python3_4 )

inherit distutils-r1 vcs-snapshot

MY_PV=${PV/_/}

DESCRIPTION="Expressive and extensible TDD/BDD assertion library for Python"
HOMEPAGE="https://github.com/jaimegildesagredo/expects"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE="doc test"

DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/mamba[${PYTHON_USEDEP}] )
"
RDEPEND=""

python_compile_all() {
use doc && emake -C docs html
}

python_test() {
mamba || die "tests failed under ${EPYTHON}"
}

python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html/. )

distutils-r1_python_install_all
}

0 comments on commit cfde437

Please sign in to comment.