Skip to content

Commit

Permalink
app-laptop/pbbuttonsd: Version bump.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
Jeroen Roovers committed Apr 22, 2017
1 parent f9189e9 commit d03521d
Show file tree
Hide file tree
Showing 2 changed files with 138 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-laptop/pbbuttonsd/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST pbbuttonsd-0.8.1.tar.gz 589630 SHA256 b391fd98ed263f355d7e7addc6566959e986627c87dcfdaa1da15310ad70bffa SHA512 856f8533c1f6489986c232baa8b8002a01d009ed3728ee35bc723aece91ba626ce961119c0d424f40c2f9289827f317c56d70fe8f0e035cbd9f08d7701316ac3 WHIRLPOOL 21a18a9f6a204156beb7373f89c6477c68ef90d8d9fe15cb7322b811b15856fd38bca7705860584716b00cd29378b85d0f2ac7624f00fe50ec44ac83033c073b
DIST pbbuttonsd-0.8.1a.tar.gz 589747 SHA256 254cc391bcb0a4a58a62224b4cca2b29fdf9ca174c1dc18ab0784f1a86465ed1 SHA512 4aaf674872982925f7aa8e06a363f50830f13d9491f4a3b850c1852a8a6d4b2c72164f839c482eed059703dd25d900fe3bb774f78e7039ac2464ea7a1837bf99 WHIRLPOOL ee17f8ff9c39c84b40aa39a6652b18de2c1a183972f4d0cb2585b46ddf6f0d34d9b8af2b7460f84fa0ee19d99497cbe6240996e3f58eb6b83f8053fdc7616165
137 changes: 137 additions & 0 deletions app-laptop/pbbuttonsd/pbbuttonsd-0.8.1a.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,137 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit autotools flag-o-matic

DESCRIPTION="Handles power management and special keys on laptops"
HOMEPAGE="http://pbbuttons.berlios.de"
SRC_URI="mirror://sourceforge/pbbuttons/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="acpi alsa doc ibam macbook oss static-libs"

RDEPEND="
>=dev-libs/glib-2.6
alsa? ( >=media-libs/alsa-lib-1.0 )
macbook? (
sys-apps/pciutils
sys-libs/libsmbios
)
"
DEPEND="
${RDEPEND}
doc? ( app-doc/doxygen )
"
PATCHES=(
"${FILESDIR}/cpufreq.patch"
"${FILESDIR}/fnmode.patch"
"${FILESDIR}/laptopmode.sh.patch"
"${FILESDIR}/lm.patch"
"${FILESDIR}/lz.patch"
)

src_prepare() {
### Don't link with g++ if we don't use ibam
if ! use ibam; then
eapply "${FILESDIR}/g++.patch"
fi

default

eautoconf
}

src_configure() {
# Fix crash bug on some systems
replace-flags -O? -O1

if use macbook; then
laptop=macbook
elif use x86 || use amd64; then
if use acpi; then
laptop=acpi
else
laptop=i386
fi
# Default to PowerBook
else
laptop=powerbook
fi

laptop=$laptop \
econf \
$(use_with alsa) \
$(use_with doc doxygen_docs) \
$(use_with ibam) \
$(use_with oss)

}

src_compile() {
# Thanks to Stefan Bruda for this workaround
# Using -j1 fixes a parallel build issue with the docs
if use doc; then
emake -j1
else
emake
fi
}

src_install() {
dodir /etc/power
use ibam && dodir /var/lib/ibam

default

use static-libs || rm "${D}"/usr/$(get_libdir)/libpbb.a

newinitd "${FILESDIR}/pbbuttonsd.rc6" pbbuttonsd
dodoc README
use doc && dodoc -r doc/

dodir /etc/power/resume.d
dodir /etc/power/suspend.d
dodir /etc/power/scripts.d
exeinto /etc/power/scripts.d
doexe "${FILESDIR}"/wireless
ln -s "${D}"/etc/power/scripts.d/wireless "${D}"/etc/power/resume.d/wireless
}

pkg_postinst() {
if [ -e /etc/pbbuttonsd.conf ]; then
ewarn "The pbbuttonsd.cnf file replaces /etc/pbuttonsd.conf with a new"
ewarn "file (/etc/pbbuttonsd.conf) and a new format. Please check the"
ewarn "manual page with 'man pbbuttonsd.cnf' for details."
ewarn
fi

if use macbook; then
ewarn "Macbook and Macbook Pro users should make sure to have applesmc"
ewarn "loaded before starting pbbuttonsdm otherwise auto-adjustments"
ewarn "will not work and pbbuttonsd may segfault."
ewarn
fi

ewarn "Ensure that the evdev kernel module is loaded otherwise"
ewarn "pbbuttonsd won't work. SysV IPC is also required."
ewarn
ewarn "If you need extra security, you can tell pbbuttonsd to only accept"
ewarn "input from one user. You can set the userallowed option in"
ewarn "/etc/pbbuttonsd.cnf to limit access."
ewarn

if use ibam; then
elog "To properly initialize the IBaM battery database, you will"
elog "need to perform a full discharge/charge cycle. For more"
elog "details, please see the pbbuttonsd man page."
elog
fi

elog "A script is now available to reset your wirless connection on resume."
elog "Simply uncomment the commented command and set the correct device to"
elog "use it. You can find the script in /etc/power/resume.d/wireless"

}

0 comments on commit d03521d

Please sign in to comment.