Skip to content

Commit

Permalink
sys-apps/pcsc-tools: version bump
Browse files Browse the repository at this point in the history
Bug: 557258

Package-Manager: portage-2.2.20
  • Loading branch information
alonbl committed Aug 11, 2015
1 parent d8dc95e commit d03982c
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-apps/pcsc-tools/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST pcsc-tools-1.4.22.tar.gz 109458 SHA256 615592dd56627bd0ff3650608bb7eefe3e9f43cc18ca2d805ebf0bf74d30f307 SHA512 cb4bea7bd75e98fda5ff44e3fd680a479cddb3edd6c632951346d2a87329386b55203dc3f2f29d484c23ee4c6cb8f741aaa6b94dd16095b86c7f88f057015cf5 WHIRLPOOL 2f4141034f013970bd43050c70d24e9ab7ee076a29d86d939cc0dc250b4431b6515f04a3e21f179e015c6d80312a70e07101732085e84bf48f5645e7de306c08
DIST pcsc-tools-1.4.23.tar.gz 114495 SHA256 69ca7bb6ee23ef99e2696451f2f56072dd74adcc43272d89fd757ac8f7de4fe2 SHA512 b94fd467ded600f6ad47510225d325635a227f2bbbe8dbb191fee31a3ccaff951d0ea4a7184765912f00dbf4725b5fcbc478b769fc0dd4369eab0a8c1d627f93 WHIRLPOOL 7ca4c25af05d4f8bebe5a73a3d4e9409d882c42816a25139d218c85ff2464382637ea2049bf176b73ba65a7d483075f23c2087b4a28bf9b38c0102538ca07467
DIST pcsc-tools-1.4.24.tar.gz 180792 SHA256 176ee6f791cd7437e05d921e5041a1f2265116a5a0d1079a5b8321f2cf541682 SHA512 d333b5e9988d93b1cd889ddfe7271b6cae0713422aa4884d5030f731d1f9de620b53d0857597d4e26508cd8f4db7e94ace07968b34a0c6392c358c38ed1725ae WHIRLPOOL fec763a91efaa95512f9c7b3d038bb288b21ef58e48c67020332e866330d012de24c1beec6e7fdeb383e08252274eada452c66658e9ec76ca3ad88e267a349b8
65 changes: 65 additions & 0 deletions sys-apps/pcsc-tools/pcsc-tools-1.4.24.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

EAPI="5"

inherit eutils fdo-mime multilib toolchain-funcs

DESCRIPTION="PC/SC Architecture smartcard tools"
HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/"
SRC_URI="http://ludovic.rousseau.free.fr/softwares/${PN}/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
IUSE="gtk network-cron"

RDEPEND=">=sys-apps/pcsc-lite-1.4.14"

DEPEND="${RDEPEND}
virtual/pkgconfig"
RDEPEND="${RDEPEND}
dev-perl/pcsc-perl
gtk? ( dev-perl/gtk2-perl )"

src_prepare() {
sed -i -e 's:-Wall -O2:$(CFLAGS):g' Makefile
}

src_compile() {
# explicitly only build the pcsc_scan application, or the man
# pages will be gzipped first, and then unpacked.
emake pcsc_scan CC=$(tc-getCC)
}

src_install() {
# install manually, makes it much easier since the Makefile
# requires fiddling with
dobin ATR_analysis scriptor pcsc_scan
doman pcsc_scan.1 scriptor.1p ATR_analysis.1p

dodoc README Changelog

if use gtk; then
domenu gscriptor.desktop
dobin gscriptor
doman gscriptor.1p
fi

if use network-cron ; then
exeinto /etc/cron.monthly
newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
fi

insinto /usr/share/pcsc
doins smartcard_list.txt
}

pkg_postinst() {
use gtk && fdo-mime_desktop_database_update
}

pkg_postrm() {
fdo-mime_desktop_database_update
}

0 comments on commit d03982c

Please sign in to comment.