Skip to content

Commit

Permalink
net-analyzer/smokeping: Version 2.7.0.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.20, Repoman-2.3.6
  • Loading branch information
Jeroen Roovers committed Feb 4, 2018
1 parent 4dfd050 commit d0448bd
Show file tree
Hide file tree
Showing 2 changed files with 151 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-analyzer/smokeping/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST smokeping-2.6.10.tar.gz 415383 BLAKE2B 7a502eddeb634404e379df67470595cf85512d64a5e137f6d7c344ceb606f99275016e1044ec820b2e9217e1d1b567164b636186bfe54e91249d585ef75c646a SHA512 e91ac80ceafccb945ec48cc80020b8cbf2afe29b5f422dc5aaf7c52387eafc498180c293cf82dccc4fdec88ec56f80fb1bd08ebcb2ae9aea563475a069b91f13
DIST smokeping-2.6.11.tar.gz 417338 BLAKE2B e1ff2fc05fd8d39f42e1cc89831aa36ef0522716d1768dba9bdedf09f6c64cc2b35f30c3b727959dd93ed8922235729a27c85acceb1e1c3ec9c5f60e21455ab9 SHA512 928722832d6e01ffbb7b74542678f7b9d5fc22819c0feae164ce58b8d8a5595800f617c8a672e07cae4b2c4ccbfa4883a11438ba2a172fc2887abc2933388422
DIST smokeping-2.6.9.tar.gz 427185 BLAKE2B 3b626d852542f5e9e616ce88a8fd2fd773036822f10f548a1cec242f5d420ec67d940ee49c08da99f7e0815921251cb474b103c8c12c364f90651a4e74e9abf3 SHA512 ab3cec15fd9f90510f902da7ce5bac5915558cac198cc88f0ce193a53a0158c9055e28c8c6671cc6653ac42ab51346e1eb19e537f1ab5c234fd498c6b777499d
DIST smokeping-2.7.0.tar.gz 8914621 BLAKE2B a139fdcaafe37c61695ea2e31e3ddaeb4389f754f28fd41318db120f2ae5f4b5f355ebfb5e0c852b48e2e6872194952bc3733ff5f6bcd2886859a1c276835121 SHA512 17ada10e2cdc7966e81e589dec603fe77bc0a273790734b36342ff2b8ac3d5bca6797f6eb95a6e2e22a576b7bb5d2ca4232b4fb23057b360de9c156d141ed0ca
150 changes: 150 additions & 0 deletions net-analyzer/smokeping/smokeping-2.7.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,150 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit autotools eutils multilib user systemd

DESCRIPTION="A powerful latency measurement tool"
HOMEPAGE="http://oss.oetiker.ch/smokeping/"
SRC_URI="http://oss.oetiker.ch/smokeping/pub/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
# dropping hppa and sparc because of way too may dependencies not having
# keywords in those architectures.
KEYWORDS="~amd64 ~x86"

# removing fcgi useflag as the configure script can't avoid it without patching
IUSE="apache2 curl dig echoping ipv6 radius"

DEPEND="
>=dev-lang/perl-5.8.8-r8
>=dev-perl/SNMP_Session-1.13
>=net-analyzer/fping-2.4_beta2-r2[suid]
>=net-analyzer/rrdtool-1.2[graph,perl]
dev-perl/CGI
dev-perl/CGI-Session
dev-perl/Config-Grammar
dev-perl/Digest-HMAC
dev-perl/FCGI
dev-perl/IO-Socket-SSL
dev-perl/IO-Tty
dev-perl/Net-DNS
dev-perl/Net-OpenSSH
dev-perl/Net-SNMP
dev-perl/Net-Telnet
dev-perl/libwww-perl
dev-perl/perl-ldap
virtual/perl-libnet
|| ( dev-perl/CGI-Fast <dev-perl/CGI-4 )
!apache2? ( virtual/httpd-cgi )
apache2? (
>=www-apache/mod_perl-2.0.1
www-apache/mod_fcgid
)
curl? ( >=net-misc/curl-7.21.4 )
dig? ( net-dns/bind-tools )
echoping? ( >=net-analyzer/echoping-6.0.2 )
ipv6? ( >=dev-perl/Socket6-0.20 )
radius? ( dev-perl/Authen-Radius )
"

RDEPEND="${DEPEND}"

pkg_setup() {
enewgroup smokeping
enewuser smokeping -1 -1 /var/lib/smokeping smokeping
}

src_prepare() {
default

sed -i -e '/^SUBDIRS = / s|thirdparty||g' Makefile.am || die
sed -i -e '/^perllibdir = / s|= .*|= $(libdir)|g' lib/Makefile.am || die
rm -r lib/{BER.pm,SNMP_Session.pm,SNMP_util.pm} || die # dev-perl/SNMP_Session
echo ${PV} > VERSION

eautoreconf
}

src_configure() {
econf \
--sysconfdir=/etc/smokeping \
--with-htdocs-dir=/var/www/localhost/smokeping
}

src_compile() {
LC_ALL=C emake
}

src_install() {
dodir /usr/$(get_libdir)
default

newinitd "${FILESDIR}"/${PN}.init.4 ${PN}
systemd_dotmpfilesd "${FILESDIR}"/"${PN}".conf
systemd_dounit "${FILESDIR}"/"${PN}".service

mv "${D}/etc/smokeping/basepage.html.dist" "${D}/etc/smokeping/basepage.html"
mv "${D}/etc/smokeping/config.dist" "${D}/etc/smokeping/config"
mv "${D}/etc/smokeping/smokemail.dist" "${D}/etc/smokeping/smokemail"
mv "${D}/etc/smokeping/smokeping_secrets.dist" "${D}/etc/smokeping/smokeping_secrets"
mv "${D}/etc/smokeping/tmail.dist" "${D}/etc/smokeping/tmail"

sed -i \
-e '/^imgcache/{s:\(^imgcache[ \t]*=\).*:\1 /var/lib/smokeping/.simg:}' \
-e '/^imgurl/{s:\(^imgurl[ \t]*=\).*:\1 ../.simg:}' \
-e '/^datadir/{s:\(^datadir[ \t]*=\).*:\1 /var/lib/smokeping:}' \
-e '/^piddir/{s:\(^piddir[ \t]*=\).*:\1 /run/smokeping:}' \
-e '/^cgiurl/{s#\(^cgiurl[ \t]*=\).*#\1 http://some.place.xyz/perl/smokeping.pl#}' \
-e '/^smokemail/{s:\(^smokemail[ \t]*=\).*:\1 /etc/smokeping/smokemail:}' \
-e '/^tmail/{s:\(^tmail[ \t]*=\).*:\1 /etc/smokeping/tmail:}' \
-e '/^secrets/{s:\(^secrets[ \t]*=\).*:\1 /etc/smokeping/smokeping_secrets:}' \
-e '/^template/{s:\(^template[ \t]*=\).*:\1 /etc/smokeping/basepage.html:}' \
"${D}/etc/${PN}/config" || die

sed -i \
-e '/^<script/{s:cropper/:/cropper/:}' \
"${D}/etc/${PN}/basepage.html" || die

sed -i \
-e 's/$FindBin::Bin\/..\/etc\/config/\/etc\/smokeping\/config/g' \
"${D}/usr/bin/smokeping" "${D}/usr/bin/smokeping_cgi" || die

sed -i \
-e 's:etc/config.dist:/etc/smokeping/config:' \
"${D}/usr/bin/tSmoke" || die

sed -i \
-e 's:/usr/etc/config:/etc/smokeping/config:' \
"${D}/var/www/localhost/smokeping/smokeping.fcgi.dist" || die

dodir /var/www/localhost/cgi-bin
mv "${D}/var/www/localhost/smokeping/smokeping.fcgi.dist" \
"${D}/var/www/localhost/cgi-bin/smokeping.fcgi"

fperms 700 /etc/${PN}/smokeping_secrets

if use apache2 ; then
insinto /etc/apache2/modules.d
doins "${FILESDIR}/79_${PN}.conf"
fi

# Create the files in /var for rrd file storage
keepdir /var/lib/${PN}/.simg
fowners smokeping:smokeping /var/lib/${PN}

if use apache2 ; then
fowners apache:apache /var/lib/${PN}/.simg
fowners -R apache:apache /var/www
else
fowners smokeping:smokeping /var/lib/${PN}/.simg
fi

fperms 775 /var/lib/${PN} /var/lib/${PN}/.simg
}

pkg_postinst() {
chown smokeping:smokeping "${ROOT}/var/lib/${PN}"
chmod 755 "${ROOT}/var/lib/${PN}"
}

0 comments on commit d0448bd

Please sign in to comment.