forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-editors/kile: add 2.9.93_p20221123, EAPI-8 bump
w/o KEYWORDS to let mirrors pick up the distfile. Signed-off-by: Andreas Sturmlechner <[email protected]>
- Loading branch information
Showing
3 changed files
with
99 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST kile-2.9.93.tar.bz2 8580239 BLAKE2B a43f160240dfdffc23c6898385994ee4e49e1f3d793915d1f392e41f606350269f2b9e80592c373680adb56454510abdd0b7e69131f20737fb5efa54d4eaa111 SHA512 d87277b8ef16c82cfd415dd191916641fa1a25e316e1eb2c463b275d3654dcfe180bea03027589ab30cd8b769d92d97005846a78aff8058bcfb20eed76287504 | ||
DIST kile-2.9.93_p20221123-1ca67389.tar.gz 9507069 BLAKE2B 61770aeafe6604b8a45ae9e49fc79a375815fce5e11a189aef962172f60d0182984f6908a626cb95b493f1fe894958ec0816420096a12efbd03233114e0a5dcc SHA512 ed16cfb7cee3d08ad21fabecd5536981c68431261c02f66cc979f5f01229fa33c192c33f5d1ef78d61c37e643ab313eb432fd580aea61f5a918d3de76d2dcadc |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,31 @@ | ||
From 2974fba837aef46711d9e1b26cd367aab68ba53a Mon Sep 17 00:00:00 2001 | ||
From: Andreas Sturmlechner <[email protected]> | ||
Date: Wed, 19 Dec 2018 13:36:12 +0100 | ||
Subject: [PATCH] Disable install misc files by cmake | ||
|
||
AUTHORS, README, Changelog etc. are handled by distribution packages. | ||
--- | ||
CMakeLists.txt | 7 ------- | ||
1 file changed, 7 deletions(-) | ||
|
||
diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
index 91a732ab..c69c168c 100644 | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -114,13 +114,6 @@ install( | ||
kile2.0-5_upd.pl | ||
DESTINATION ${KDE_INSTALL_DATAROOTDIR}/kconf_update) | ||
|
||
-install(FILES | ||
- AUTHORS | ||
- ChangeLog | ||
- README | ||
- README.cwl | ||
- kile-remote-control.txt | ||
- DESTINATION ${KDE_INSTALL_DATAROOTDIR}/doc/kile) | ||
|
||
ki18n_install(po) | ||
|
||
-- | ||
2.38.1 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,67 @@ | ||
# Copyright 1999-2022 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
ECM_HANDBOOK="forceoptional" | ||
KDE_ORG_CATEGORY="office" | ||
KDE_ORG_COMMIT="1ca67389327d63fdc5a4c65ab6dd1cf7fbf597af" | ||
KFMIN=5.82.0 | ||
QTMIN=5.15.5 | ||
MY_P=${P/_beta/b} | ||
inherit ecm kde.org | ||
|
||
DESCRIPTION="Latex Editor and TeX shell based on KDE Frameworks" | ||
HOMEPAGE="https://apps.kde.org/kile/ https://kile.sourceforge.io/" | ||
|
||
LICENSE="FDL-1.2 GPL-2" | ||
SLOT="5" | ||
# KEYWORDS="~amd64 ~arm64 ~riscv ~x86" | ||
IUSE="+pdf +png" | ||
|
||
DEPEND=" | ||
>=dev-qt/qtdbus-${QTMIN}:5 | ||
>=dev-qt/qtscript-${QTMIN}:5 | ||
>=dev-qt/qttest-${QTMIN}:5 | ||
>=dev-qt/qtwidgets-${QTMIN}:5 | ||
kde-apps/okular:5 | ||
>=kde-frameworks/kconfig-${KFMIN}:5 | ||
>=kde-frameworks/kcoreaddons-${KFMIN}:5 | ||
>=kde-frameworks/kcrash-${KFMIN}:5 | ||
>=kde-frameworks/kdbusaddons-${KFMIN}:5 | ||
>=kde-frameworks/kdoctools-${KFMIN}:5 | ||
>=kde-frameworks/kguiaddons-${KFMIN}:5 | ||
>=kde-frameworks/ki18n-${KFMIN}:5 | ||
>=kde-frameworks/kiconthemes-${KFMIN}:5 | ||
>=kde-frameworks/kio-${KFMIN}:5 | ||
>=kde-frameworks/kparts-${KFMIN}:5 | ||
>=kde-frameworks/ktexteditor-${KFMIN}:5 | ||
>=kde-frameworks/kwindowsystem-${KFMIN}:5 | ||
>=kde-frameworks/kxmlgui-${KFMIN}:5 | ||
pdf? ( app-text/poppler[qt5] ) | ||
" | ||
RDEPEND="${DEPEND} | ||
kde-apps/konsole:5 | ||
kde-apps/okular:5[pdf?] | ||
virtual/latex-base | ||
virtual/tex-base | ||
pdf? ( | ||
app-text/ghostscript-gpl | ||
app-text/texlive-core | ||
) | ||
png? ( | ||
app-text/dvipng | ||
virtual/imagemagick-tools[png?] | ||
) | ||
" | ||
|
||
DOCS=( kile-remote-control.txt ) | ||
|
||
PATCHES=( "${FILESDIR}/${P}-cmake.patch" ) | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
$(cmake_use_find_package pdf Poppler) | ||
) | ||
ecm_src_configure | ||
} |