Skip to content

Commit

Permalink
dev-scheme/chez: bump to 9.5.8
Browse files Browse the repository at this point in the history
Signed-off-by: Maciej Barć <[email protected]>
  • Loading branch information
xgqt committed Apr 25, 2022
1 parent 79969d5 commit d07e7ff
Show file tree
Hide file tree
Showing 2 changed files with 70 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-scheme/chez/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST chez-9.5.6.tar.gz 34565487 BLAKE2B 5d74cd3365b3039e6be1b774213da75da1080beffb1c9b5044466a8feff0171ce75d9999e69774754a5969d68825c571a88cb27d57af2718e98668e4fe936e3c SHA512 4affd73a5b2ea5cdec01fb200a32499387fc3769b7677ffe7d854f6a5567d50ba114f9f12951f99d8e0fd757c799e82e32c83079fae83e5fc138ee6e1a5f56c0
DIST chez-9.5.8.tar.gz 35487100 BLAKE2B 6c5467f812788166aded14ce38ec2935bb890f2386f3ea7ec29a97c6a3d9aa37f26960e44aa6acd6b3954e45dfc4eaff4fc7db1dd77b231fb380a1dac7349be4 SHA512 80a4e9f61ddb254bef1a249af1d32f918df88390946fbe6eeb62c3510c760bf899285be1aba70eda9b54bcb0c6fef3fe7deace648993cd9cece2d08cf0ade9c0
69 changes: 69 additions & 0 deletions dev-scheme/chez/chez-9.5.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,69 @@
# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

CSV="csv${PV}"

inherit toolchain-funcs

DESCRIPTION="A programming language based on R6RS"
HOMEPAGE="https://cisco.github.io/ChezScheme/ https://github.com/cisco/ChezScheme"
SRC_URI="https://github.com/cisco/ChezScheme/releases/download/v${PV}/${CSV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${CSV}"

# Chez Scheme itself is Apache 2.0, but it vendors LZ4 (BSD-2),
# Nanopass (MIT), stex (MIT), and zlib (ZLIB).
LICENSE="Apache-2.0 BSD-2 MIT ZLIB"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="X examples ncurses threads"

BDEPEND="virtual/pkgconfig"
RDEPEND="
X? ( x11-libs/libX11 )
ncurses? ( sys-libs/ncurses:= )
"
DEPEND="${RDEPEND}"

src_prepare() {
tc-export AR CC CXX LD RANLIB

default

if use ncurses ; then
local nclibs="\"$($(tc-getPKG_CONFIG) --libs ncurses)\""
sed -i "s|ncursesLib=-lncurses|ncursesLib=${nclibs}|g" configure || die
fi

# Remove -Werror
sed -i "/^C = /s|-Werror||g" c/Mf-* || die
}

src_configure() {
local myconfargs=(
$(usex threads '--threads' '')
$(usex ncurses '' '--disable-curses')
$(usex X '' '--disable-x11')
--installprefix="/usr"
--installbin="/usr/bin"
--installlib="/usr/$(get_libdir)"
--installman="/usr/share/man"
--installschemename=chezscheme
--installpetitename=chezscheme-petite
--installscriptname=chezscheme-script
--nogzip-man-pages
)
sh ./configure "${myconfargs[@]}" || die
}

src_install() {
# TempRoot == DESTDIR
emake TempRoot="${D}" install

if ! use examples; then
rm -r "${D}/usr/$(get_libdir)/${CSV}/examples" || die
fi

einstalldocs
}

0 comments on commit d07e7ff

Please sign in to comment.