Skip to content

Commit

Permalink
app-office/libreoffice: Fix system-pyuno patch, missing deps
Browse files Browse the repository at this point in the history
--disable-pdfium until it is packaged

Thanks-to: jospezial <[email protected]>
Gentoo-bug: 609050, 609054

Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
a17r committed Feb 26, 2017
1 parent b08cfc5 commit d092900
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 3 deletions.
42 changes: 42 additions & 0 deletions app-office/libreoffice/files/libreoffice-5.4-system-pyuno.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
--- a/desktop/scripts/soffice.sh
+++ a/desktop/scripts/soffice.sh
@@ -147,6 +147,9 @@ if echo "$checks" | grep -q "cc" ; then
exit 1;
fi

+PYTHONPATH=$sd_prog${PYTHONPATH+:$PYTHONPATH}
+export PYTHONPATH
+
case "$(uname -s)" in
NetBSD|OpenBSD|DragonFly)
# this is a temporary hack until we can live with the default search paths
--- a/pyuno/source/module/uno.py
+++ a/pyuno/source/module/uno.py
@@ -16,11 +16,16 @@
# except in compliance with the License. You may obtain a copy of
# the License at http://www.apache.org/licenses/LICENSE-2.0 .
#
+import os
import pyuno
import sys
import traceback
import warnings

+sys.path.append('%eprefix%/usr/%libdir%/libreoffice/program')
+if getattr(os.environ, 'URE_BOOTSTRAP', None) is None:
+ os.environ['URE_BOOTSTRAP'] = "vnd.sun.star.pathname:%eprefix%/usr/%libdir%/libreoffice/program/fundamentalrc"
+
# since on Windows sal3.dll no longer calls WSAStartup
import socket

--- a/pyuno/source/officehelper.py
+++ a/pyuno/source/officehelper.py
@@ -45,7 +45,7 @@ def bootstrap():
if "UNO_PATH" in os.environ:
sOffice = os.environ["UNO_PATH"]
else:
- sOffice = "" # lets hope for the best
+ sOffice = "%eprefix%/usr/%libdir%/libreoffice/program"
sOffice = os.path.join(sOffice, "soffice")
if platform.startswith("win"):
sOffice += ".exe"
10 changes: 7 additions & 3 deletions app-office/libreoffice/libreoffice-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -89,7 +89,7 @@ KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
COMMON_DEPEND="${PYTHON_DEPS}
app-arch/unzip
app-arch/zip
app-crypt/gpgme
app-crypt/gpgme[cxx]
app-text/hunspell
>=app-text/libabw-0.1.0
>=app-text/libebook-0.1
Expand All @@ -112,6 +112,8 @@ COMMON_DEPEND="${PYTHON_DEPS}
dev-libs/expat
dev-libs/hyphen
dev-libs/icu:=
dev-libs/libassuan
dev-libs/libgpg-error
>=dev-libs/liborcus-0.12.1
dev-libs/librevenge
dev-libs/nspr
Expand Down Expand Up @@ -244,7 +246,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}

PATCHES=(
# not upstreamable stuff
"${FILESDIR}/${PN}-5.3-system-pyuno.patch"
"${FILESDIR}/${PN}-5.4-system-pyuno.patch"

# TODO: upstream
"${FILESDIR}/${PN}-5.2.5.1-glibc-2.24.patch"
Expand Down Expand Up @@ -434,6 +436,7 @@ src_configure() {
# --disable-report-builder: too much java packages pulled in without pkgs
# --without-system-sane: just sane.h header that is used for scan in writer,
# not linked or anything else, worthless to depend on
# --disable-pdfium: not yet packaged
econf \
--with-system-dicts \
--with-system-epoxy \
Expand All @@ -454,6 +457,7 @@ src_configure() {
--disable-fetch-external \
--disable-gstreamer-0-10 \
--disable-online-update \
--disable-pdfium \
--disable-report-builder \
--with-alloc=$(use jemalloc && echo "jemalloc" || echo "system") \
--with-build-version="Gentoo official package" \
Expand All @@ -471,7 +475,7 @@ src_configure() {
--without-myspell-dicts \
--without-help \
--with-helppack-integration \
--with-system-gpgme \
--with-system-gpgmepp \
--without-system-sane \
$(use_enable bluetooth sdremote-bluetooth) \
$(use_enable coinmp) \
Expand Down

0 comments on commit d092900

Please sign in to comment.