Skip to content

Commit

Permalink
app-accessibility/at-spi2-core: Version bump to 2.40.1
Browse files Browse the repository at this point in the history
Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
mattst88 committed May 1, 2021
1 parent 27e679f commit d0a2bec
Show file tree
Hide file tree
Showing 2 changed files with 63 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-accessibility/at-spi2-core/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST at-spi2-core-2.38.0.tar.xz 190540 BLAKE2B 6c5c479c279285460a5ff80533d600b5173fe9bedacfa1522bc37da4a305b965cec2c677eaae8be809ed1a5fd8aaef6475fd27b80510efd1c530e46368e954af SHA512 3a1eb27cff6e0dd03119b4f8361a3b6037b26c511e80e2d003d1d5c41fede6d49eb5e0ac1ee45cfb4f3ca8e53292a7e2da67df80be28e77014775e41777a96c1
DIST at-spi2-core-2.40.0.tar.xz 197080 BLAKE2B 56c0ca8138b5178d713851ffb9a9299544a65708a3e5bf37b1e59e515bb30fccffd8b8cc9dea1e78c32a5d1fa3d21de506ef674c5e0ab8067a8ff5df206d349a SHA512 45f9123dac27982003e4c5e357ddaf31dbe945ff334bf1a7d02e81011b841bd69c717233e8b2d33abb6cfe16320bfe5893499f25d9f603cde5d11d63315e8725
DIST at-spi2-core-2.40.1.tar.xz 197064 BLAKE2B dfa19413e6688678fcc0c0ed76d0fca0d5de5039c9b1e42dc10c9c387c0cbffb3c6a38570f9e74c343fa86310f2c3f6fcf0e311c57d11b5adeac5faf7bdf9630 SHA512 fcb73e78a85db9b982ae10d8c968c7732079832877fa0214c30a04b9e27910448c3f5456b8628ed4a3d4dbd59037c8c206916ad1462ca5c7a44409a702096b14
62 changes: 62 additions & 0 deletions app-accessibility/at-spi2-core/at-spi2-core-2.40.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit gnome.org meson multilib-minimal systemd virtualx xdg

DESCRIPTION="D-Bus accessibility specifications and registration daemon"
HOMEPAGE="https://wiki.gnome.org/Accessibility"

LICENSE="LGPL-2.1+"
SLOT="2"
IUSE="X gtk-doc +introspection"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"

RDEPEND="
>=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
>=dev-libs/glib-2.62:2[${MULTILIB_USEDEP}]
introspection? ( >=dev-libs/gobject-introspection-1.54.0:= )
X? (
x11-libs/libX11[${MULTILIB_USEDEP}]
x11-libs/libXtst[${MULTILIB_USEDEP}]
x11-libs/libXi[${MULTILIB_USEDEP}]
)
"
DEPEND="${RDEPEND}"
BDEPEND="
dev-util/glib-utils
gtk-doc? (
>=dev-util/gtk-doc-1.25
app-text/docbook-xml-dtd:4.3
)
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
"

PATCHES=(
# disable teamspaces test since that requires Novell.ICEDesktop.Daemon
"${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
)

multilib_src_configure() {
local emesonargs=(
-Dsystemd_user_dir="$(systemd_get_userunitdir)"
-Ddocs=$(multilib_native_usex gtk-doc true false)
-Dintrospection=$(multilib_native_usex introspection)
-Dx11=$(usex X)
)
meson_src_configure
}

multilib_src_compile() {
meson_src_compile
}

multilib_src_test() {
virtx dbus-run-session meson test -C "${BUILD_DIR}"
}

multilib_src_install() {
meson_src_install
}

0 comments on commit d0a2bec

Please sign in to comment.