Skip to content

Commit

Permalink
dev-libs/libevdev: add live ebuild
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.41, Repoman-2.3.9
  • Loading branch information
hanetzer authored and tonyvroon committed Jul 13, 2018
1 parent d6f4875 commit d0bf18a
Showing 1 changed file with 48 additions and 0 deletions.
48 changes: 48 additions & 0 deletions dev-libs/libevdev/libevdev-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )

inherit multilib-minimal python-any-r1

DESCRIPTION="Handler library for evdev events"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/libevdev/"

if [[ ${PV} == 9999* ]] ; then
EGIT_REPO_URI="https://anongit.freedesktop.org/git/libevdev.git"
inherit autotools git-r3
else
SRC_URI="https://www.freedesktop.org/software/libevdev/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi

LICENSE="MIT"
SLOT="0"
IUSE="doc static-libs"

BDEPEND="
${PYTHON_DEPS}
doc? ( app-doc/doxygen )
virtual/pkgconfig
"
RESTRICT="test" # Tests need to run as root.

src_prepare() {
default
[[ ${PV} == 9999* ]] && eautoreconf
}

multilib_src_configure() {
ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
}

multilib_src_install() {
default
find "${D}" -name '*.la' -delete || die
if use doc ;then
local HTML_DOCS=( doc/html/. )
einstalldocs
fi
}

0 comments on commit d0bf18a

Please sign in to comment.