forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-strategy/freeorion: Bump to 0.4.5
Package-Manager: portage-2.2.20.1
- Loading branch information
Showing
2 changed files
with
100 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST freeorion-0.4.5.tar.gz 133309719 SHA256 3b99b92eeac72bd059566dbabfab54368989ba83f72e769bc94eb8dd4fe414c0 SHA512 4107b3019a19f970e7a7df595940a95ad411cbe9572c88b9561de0a2612e107bb654eb3e87a53062f6d969383f4363d7710556d6ba0ae4943c92931be9b650c1 WHIRLPOOL e7488f8d336f36df2d2bf51ab32cd3b2e62eb1c2b1e80596100806f8da1e9064556ccbfa196b77b594f58565e3466a40b7347f3962df4ebe62a1f2c8f9e429fe | ||
DIST freeorion-0.4.5_pre.tar.bz2 141068240 SHA256 a3d326a1fa05327cf23b14ef08672c0199fc08df15bb3679f579575115172b4a SHA512 33dc4a89264ccf8f146021d8b9dabc51f11e7869a5323effb7a783800db77f37ed27880c60c483dd83ea62bc9ea84872f53c25b4571ccdf13dc594bcb368b903 WHIRLPOOL 1229aefdc22b95c38e71a94f493026230e750948c37544f636d1a43030b96d487307a7a1885bb32d4ae697bc64f431b97323cb647eca516d3363898120528d0d |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,99 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
PYTHON_COMPAT=( python2_7 ) | ||
inherit cmake-utils python-any-r1 games | ||
|
||
DESCRIPTION="A free turn-based space empire and galactic conquest game" | ||
HOMEPAGE="http://www.freeorion.org" | ||
SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/FreeOrion_v0.4.5_2015-09-01.f203162_Source.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2 LGPL-2.1 CC-BY-SA-3.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
IUSE="cg" | ||
|
||
# Needs it's own version of GG(dev-games/gigi) which it ships. | ||
# The split version dev-games/gigi is not used anymore as of 0.4.3 | ||
RDEPEND=" | ||
!dev-games/gigi | ||
media-libs/libsdl2 | ||
>=dev-libs/boost-1.47[python] | ||
media-libs/freealut | ||
media-libs/glew | ||
media-libs/libogg | ||
media-libs/libsdl[X,opengl,video] | ||
media-libs/libvorbis | ||
media-libs/openal | ||
sci-physics/bullet | ||
sys-libs/zlib | ||
virtual/opengl" | ||
DEPEND="${RDEPEND} | ||
${PYTHON_DEPS} | ||
virtual/pkgconfig" | ||
|
||
CMAKE_USE_DIR="${S}" | ||
CMAKE_VERBOSE="1" | ||
|
||
pkg_setup() { | ||
# build system is using FindPythonLibs.cmake which needs python:2 | ||
python-any-r1_pkg_setup | ||
games_pkg_setup | ||
} | ||
|
||
src_unpack() { | ||
default | ||
mv src-tarball "${P}" || die | ||
} | ||
|
||
src_prepare() { | ||
# parse subdir sets -O3 | ||
sed -e "s:-O3::" -i parse/CMakeLists.txt | ||
|
||
# For snapshots, the following can be used to the set revision | ||
# for display in game -- update on bump! | ||
# sed -i -e 's/???/8051/' CMakeLists.txt | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DRELEASE_COMPILE_FLAGS="" | ||
-DCMAKE_SKIP_RPATH=ON | ||
) | ||
|
||
cmake-utils_src_configure | ||
} | ||
|
||
src_compile() { | ||
cmake-utils_src_compile | ||
} | ||
|
||
src_install() { | ||
# data files | ||
rm "${CMAKE_USE_DIR}"/default/COPYING || die | ||
insinto "${GAMES_DATADIR}"/${PN} | ||
doins -r "${CMAKE_USE_DIR}"/default || die | ||
|
||
# bin | ||
dogamesbin "${CMAKE_BUILD_DIR}"/${PN}{ca,d} || die | ||
newgamesbin "${CMAKE_BUILD_DIR}"/${PN} ${PN}.bin || die | ||
games_make_wrapper ${PN} \ | ||
"${GAMES_BINDIR}/${PN}.bin --resource-dir ${GAMES_DATADIR}/${PN}/default" \ | ||
"${GAMES_DATADIR}/${PN}" | ||
|
||
# lib | ||
dogameslib "${CMAKE_BUILD_DIR}"/libfreeorion{common,parse}.so || die | ||
dogameslib "${CMAKE_BUILD_DIR}"/libGiGi*.so || die | ||
|
||
# other | ||
dodoc "${CMAKE_USE_DIR}"/changelog.txt || die | ||
newicon "${CMAKE_USE_DIR}"/default/data/art/icons/FO_Icon_32x32.png \ | ||
${PN}.png || die | ||
make_desktop_entry ${PN} ${PN} ${PN} | ||
|
||
# permissions | ||
prepgamesdirs | ||
} |