Skip to content

Commit

Permalink
sys-block/tgt: 1.0.72 bup
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.3
  • Loading branch information
prometheanfire committed Aug 2, 2017
1 parent df2cb28 commit d0fdb68
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-block/tgt/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST tgt-1.0.70.tar.gz 296474 SHA256 632ed2f064652be7533e928834b55b403927ad381456b8089d903fd92a1f8e3d SHA512 fac7acde7cbd12156ea472d1bed20646dfdd5cfe607503bd1437eaeef816ba8114fe2ebd79e33cb083f8e64fee07bfbf66bcfc6b427c21de814e293e9edaeaad WHIRLPOOL b8b60f2c69e6f9199ba93eae98ca96ea2407ef1d3c26567925a9996d6430cd3f8c204630b046b74487b872ccf02729f89d046b263385e32d14b78fcd336d5e4c
DIST tgt-1.0.71.tar.gz 296540 SHA256 3f0b898ae341f5d8c84c83f9951dd7ef182eaf449dd7008e55747f144303e10b SHA512 db74deb199ef341577ab505b7202651e6c28aa9d62d37d3492b1775a2944284e1d3bb7c99b6d8bedd3456807641952876719ecd66553bd8c8dabbee5669f9428 WHIRLPOOL d19c2c5614d7b406d785cbe5b954a0aa2494b8a5b43a33e05b3f6876750039590524607b28c491cd00a60dd7a1bc57e327099fe36711a8c53798a4ec1300e295
DIST tgt-1.0.72.tar.gz 296698 SHA256 2c7f4b8f831c5124192c40b0503fd6e659154393576c37f1f80dfdc5d9b8a772 SHA512 4fdb1b8f3c2487f66629024132f7fa53ab69b9eba67d380fb18aa2d9c143e77bdf808b3ff8d1e2bf1d4420cf1792944d6f79731ddbb095d52b53d573d9f1281c WHIRLPOOL 763d5d68320f9629531f6406caab9f77c1a7f3574a6ef1a7ee7192e14f41a95169b858211eedbe84d7071e1b3801744933b09a7b81d84a6772c7d0ef5801415b
65 changes: 65 additions & 0 deletions sys-block/tgt/tgt-1.0.72.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

inherit flag-o-matic toolchain-funcs

MY_TREE="8f94634"

DESCRIPTION="Linux SCSI target framework (tgt)"
HOMEPAGE="http://stgt.sourceforge.net"
SRC_URI="https://github.com/fujita/tgt/tarball/v${PV} -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="fcoe fcp ibmvio infiniband rbd"

CDEPEND="dev-perl/Config-General
dev-libs/libxslt
rbd? ( sys-cluster/ceph )
infiniband? (
sys-fabric/libibverbs:=
sys-fabric/librdmacm:=
)"
DEPEND="${CDEPEND}
app-text/docbook-xsl-stylesheets"
RDEPEND="${DEPEND}
dev-libs/libaio
sys-apps/sg3_utils"

S=${WORKDIR}/fujita-tgt-${MY_TREE}

pkg_setup() {
tc-export CC
}

src_prepare() {
epatch "${FILESDIR}"/${PN}-1.0.69-sysmacros.patch #580594

sed -i -e 's:\($(CC)\) $^:\1 $(LDFLAGS) $^:' usr/Makefile || die

# make sure xml docs are generated before trying to install them
sed -i -e "s@install: @& all @g" doc/Makefile || die
}

src_compile() {
local myconf
use ibmvio && myconf="${myconf} IBMVIO=1"
use infiniband && myconf="${myconf} ISCSI_RDMA=1"
use fcp && myconf="${myconf} FCP=1"
use fcoe && myconf="${myconf} FCOE=1"
use rbd && myconf="${myconf} CEPH_RBD=1"

emake -C usr/ KERNELSRC="${KERNEL_DIR}" ISCSI=1 ${myconf}
emake -C doc
}

src_install() {
emake install-programs install-scripts install-doc DESTDIR="${D}" docdir=/usr/share/doc/${PF}
newinitd "${FILESDIR}"/tgtd.initd tgtd
newconfd "${FILESDIR}"/tgtd.confd tgtd
dodir /etc/tgt
keepdir /etc/tgt
}

0 comments on commit d0fdb68

Please sign in to comment.