Skip to content

Commit

Permalink
dev-libs/xmlwrapp: revision bump
Browse files Browse the repository at this point in the history
Bump EAPI to 6, add multilib support. Unbundle boost-m4,
which effectively fix building with GCC 5

Gentoo-Bug: 571502

Package-Manager: portage-2.2.26
  • Loading branch information
Pinkbyte committed Jan 27, 2016
1 parent 16184ab commit d12887e
Showing 1 changed file with 45 additions and 0 deletions.
45 changes: 45 additions & 0 deletions dev-libs/xmlwrapp/xmlwrapp-0.7.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit autotools eutils multilib-minimal

DESCRIPTION="modern style C++ library that provides a simple and easy interface to libxml2"
HOMEPAGE="http://vslavik.github.io/xmlwrapp/"
SRC_URI="https://github.com/vslavik/${PN}/releases/download/v${PV}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="static-libs"

RDEPEND="dev-libs/boost:=[${MULTILIB_USEDEP}]
dev-libs/libxml2[${MULTILIB_USEDEP}]
dev-libs/libxslt[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}
sys-devel/boost-m4"

DOCS=( AUTHORS NEWS README )

src_prepare() {
# Unbundle boost.m4
rm admin/boost.m4 || die

sed -i -e '/XMLWRAPP_VISIBILITY/d' configure.ac || die

eapply_user
eautoreconf
multilib_copy_sources
}

multilib_src_configure() {
local ECONF_SOURCE=${BUILD_DIR}
econf $(use_enable static-libs static)
}

multilib_src_install() {
default_src_install
prune_libtool_files
}

0 comments on commit d12887e

Please sign in to comment.