Skip to content

Commit

Permalink
games-engines/frotz: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.2
  • Loading branch information
austin987 committed Nov 11, 2016
1 parent d0b0de8 commit d12b75f
Show file tree
Hide file tree
Showing 3 changed files with 57 additions and 4 deletions.
4 changes: 2 additions & 2 deletions games-engines/frotz/files/frotz-2.43-glibc2.10.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- src/dumb/dumb_input.c
+++ src/dumb/dumb_input.c
--- a/src/dumb/dumb_input.c
+++ b/src/dumb/dumb_input.c
@@ -79,7 +79,7 @@
/* Read one line, including the newline, into s. Safely avoids buffer
* overruns (but that's kind of pointless because there are several
Expand Down
4 changes: 2 additions & 2 deletions games-engines/frotz/files/frotz-2.43-ldflags.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- Makefile.old 2010-10-04 14:13:37.000000000 +0200
+++ Makefile 2010-10-04 14:14:06.000000000 +0200
--- a/Makefile 2010-10-04 14:13:37.000000000 +0200
+++ b/Makefile 2010-10-04 14:14:06.000000000 +0200
@@ -162,7 +162,7 @@
$(NAME): $(NAME)-curses

Expand Down
53 changes: 53 additions & 0 deletions games-engines/frotz/frotz-2.43-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils

DESCRIPTION="Curses based interpreter for Z-code based text games"
HOMEPAGE="http://frotz.sourceforge.net/"
SRC_URI="http://www.ifarchive.org/if-archive/infocom/interpreters/frotz/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="alsa oss"

DEPEND="sys-libs/ncurses:0
alsa? ( oss? ( media-libs/alsa-oss ) )"
RDEPEND="${DEPEND}"

PATCHES=(
"${FILESDIR}"/${P}-glibc2.10.patch
"${FILESDIR}"/${P}-ldflags.patch
)

src_prepare() {
default

sed -i \
-e '/^CC /d' \
Makefile \
|| die
}

src_compile() {
local OPTS="CONFIG_DIR=/etc"
use oss && OPTS="${OPTS} SOUND_DEFS=-DOSS_SOUND SOUND_DEV=/dev/dsp"
emake ${OPTS} all
}

src_install () {
dobin {d,}frotz
doman doc/*.6
dodoc AUTHORS BUGS ChangeLog HOW_TO_PLAY README TODO \
doc/{frotz.conf-big,frotz.conf-small}
}

pkg_postinst() {
echo
elog "Global config file can be installed in /etc/frotz.conf"
elog "Sample config files are in /usr/share/doc/${PF}"
echo
}

0 comments on commit d12b75f

Please sign in to comment.