forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/harfbuzz: Bump to version 1.7.3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
- Loading branch information
Lars Wendler
committed
Dec 20, 2017
1 parent
ca3e5a9
commit d135373
Showing
2 changed files
with
105 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST harfbuzz-1.4.5.tar.bz2 1474461 BLAKE2B 8f2fb5c20c92afe3fb344bf4d4024090d68ab60c6d899c9805eec0bc6d0a714a3d98bfb6718ea4225da68b19e95db357c744dcba310076f4c56ed590985c9d1d SHA512 dd505ef950ef1d702a820987d8e93097e4c4fd9f725d18e69dd756ea21d4d5624eb2edfc8563f89947e3913bf5efa1834092e06ea02821744b0b588ce2ceb00e | ||
DIST harfbuzz-1.4.6.tar.bz2 1475086 BLAKE2B 8fb082016bc50e8ae2ab9244ae2ac0b01dc5967ab14ec6aeba52a66b4926327f6c0cb7bce0020cd8183c07c57a41de1255a5782218fda87290cbad2c29d08860 SHA512 aade3902adadf3a8339ba1d05279e639da7cb53981adc64e2a2d32a5d49335a6a9782a62cdf80beca569ec8a639792bf0368c0b6ecad08f35bc85878678aa096 | ||
DIST harfbuzz-1.7.2.tar.bz2 1708416 BLAKE2B d182bdfa163e07ff41bf36e30373470bf0dded24b1c748f1114f09b3aec628f41111c4b3d6830c3f0d46206d5468816e3efb495a023747825adcdf2a9b516e39 SHA512 a895c96a1c4096622c797a5a877e80529ce63e3bd3adea9f68994b32e13e7b3be14cdfe824d338f48b12f49de537f7d0f6db14f422ea896697667c672daeb1cc | ||
DIST harfbuzz-1.7.3.tar.bz2 1718148 BLAKE2B 5770b00084aee3b755d048d1c9a51c199b3cb0053c4059a47703651f0d7fd8f7cd3b95b89656f3d612fc9c24151bfbc4ddeb28fed79fe5eead3dd7fe53421242 SHA512 383d63e3f3ec028a706be02f4fd6a69975bd6e79b84f0d41b8b9e75b015fbd0b1bdb99e23fbbb3dde6ddd649595ffd566c7cea4ed239308c7b2781a9c50d4e95 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,104 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
EGIT_REPO_URI="git://anongit.freedesktop.org/harfbuzz" | ||
[[ ${PV} == 9999 ]] && inherit git-r3 autotools | ||
|
||
PYTHON_COMPAT=( python2_7 ) | ||
|
||
inherit eutils flag-o-matic libtool multilib-minimal python-any-r1 xdg-utils | ||
|
||
DESCRIPTION="An OpenType text shaping engine" | ||
HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz" | ||
[[ ${PV} == 9999 ]] || SRC_URI="https://www.freedesktop.org/software/${PN}/release/${P}.tar.bz2" | ||
|
||
LICENSE="Old-MIT ISC icu" | ||
SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416 | ||
[[ ${PV} == 9999 ]] || \ | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris" | ||
|
||
IUSE="+cairo debug fontconfig +glib +graphite icu +introspection static-libs test +truetype" | ||
REQUIRED_USE="introspection? ( glib )" | ||
|
||
RDEPEND=" | ||
cairo? ( x11-libs/cairo:= ) | ||
fontconfig? ( media-libs/fontconfig:1.0[${MULTILIB_USEDEP}] ) | ||
glib? ( >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}] ) | ||
graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] ) | ||
icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] ) | ||
introspection? ( >=dev-libs/gobject-introspection-1.34:= ) | ||
truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] ) | ||
" | ||
DEPEND="${RDEPEND} | ||
dev-util/gtk-doc-am | ||
virtual/pkgconfig | ||
test? ( ${PYTHON_DEPS} ) | ||
" | ||
# eautoreconf requires gobject-introspection-common | ||
# ragel needed if regenerating *.hh files from *.rl | ||
[[ ${PV} = 9999 ]] && DEPEND="${DEPEND} | ||
>=dev-libs/gobject-introspection-common-1.34 | ||
dev-util/ragel | ||
" | ||
|
||
pkg_setup() { | ||
use test && python-any-r1_pkg_setup | ||
if ! use debug ; then | ||
append-cppflags -DHB_NDEBUG | ||
fi | ||
} | ||
|
||
src_prepare() { | ||
default | ||
|
||
xdg_environment_reset | ||
|
||
if [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] ; then | ||
# on Darwin/Solaris we need to link with g++, like automake defaults | ||
# to, but overridden by upstream because on Linux this is not | ||
# necessary, bug #449126 | ||
sed -i \ | ||
-e 's/\<LINK\>/CXXLINK/' \ | ||
src/Makefile.am || die | ||
sed -i \ | ||
-e '/libharfbuzz_la_LINK = /s/\<LINK\>/CXXLINK/' \ | ||
src/Makefile.in || die | ||
sed -i \ | ||
-e '/AM_V_CCLD/s/\<LINK\>/CXXLINK/' \ | ||
test/api/Makefile.in || die | ||
fi | ||
|
||
[[ ${PV} == 9999 ]] && eautoreconf | ||
elibtoolize # for Solaris | ||
|
||
# failing test, https://bugs.freedesktop.org/show_bug.cgi?id=89190 | ||
sed -e 's#tests/arabic-fallback-shaping.tests##' -i test/shaping/Makefile.in || die "sed failed" | ||
} | ||
|
||
multilib_src_configure() { | ||
ECONF_SOURCE="${S}" \ | ||
# harfbuzz-gobject only used for instrospection, bug #535852 | ||
econf \ | ||
--without-coretext \ | ||
--without-uniscribe \ | ||
$(use_enable static-libs static) \ | ||
$(multilib_native_use_with cairo) \ | ||
$(use_with fontconfig) \ | ||
$(use_with glib) \ | ||
$(use_with introspection gobject) \ | ||
$(use_with graphite graphite2) \ | ||
$(use_with icu) \ | ||
$(multilib_native_use_enable introspection) \ | ||
$(use_with truetype freetype) | ||
|
||
if multilib_is_native_abi; then | ||
ln -s "${S}"/docs/html docs/html || die | ||
fi | ||
} | ||
|
||
multilib_src_install_all() { | ||
einstalldocs | ||
prune_libtool_files --modules | ||
} |