Skip to content

Commit

Permalink
app-portage/iwdevtools: add 0.5.3
Browse files Browse the repository at this point in the history
Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
ionenwks committed Sep 4, 2021
1 parent e092995 commit d1a98a5
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-portage/iwdevtools/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST iwdevtools-0.4.0.tar.gz 31939 BLAKE2B bdab037a2b27bf0c67bb453427ad7f8d7485db3f45f3c465e3b2790e8e259b1328b75eff7d86012df06a44f4101e8bc0e83c9e7a8886adc25d589ecca1a25892 SHA512 a8be15568f24d2f54178f9a92cbc4107f7fdb06da8b2a769ad19ca5b55e90896c4b2253569d7d39158765081d9f9267ff568a066edef8401ec52c29451655ee1
DIST iwdevtools-0.5.1.tar.gz 41587 BLAKE2B 30423085f5240ec05b943085e0f20cf96f00e2b98058c509c5c9c3a0d17dd2fc65916f29eded9038bcb7b7deb57d3a3e551f63a31b7dcc00100b973aaabd33af SHA512 65a677a4e5202cbb7f412168f172475736c487a5f3b72f03e7c4809b275e9c437f941b85009cfcee76602a0414c5c5e872fd346d4275b3e591daa0b6e87745c1
DIST iwdevtools-0.5.2.tar.gz 42831 BLAKE2B 85c28f829ef5a816ab3c1e6231234033e404decfa6d34726fd3c1aa09d32fa71b3c57c7e34f815752fe9a683ec6c84d052506b4beaa99a501d0a86fcf7c7aa46 SHA512 282c064fae82018de9ee4110ae7b60d410de7599e911d62162b0ef4193ae041f79a7f0213c4c608b694aa7eedc1ed5456f6edd2b37784d065aa20fc6f9086ff0
DIST iwdevtools-0.5.3.tar.gz 42845 BLAKE2B 9e6b634e8409cffc57fde36157be0186943d4df07c47f0b07eeb0dd5071bc3e4c7b84e543a46cd2ff4e49d9b9b34b9121b3583bd227479f1485ec5957dee4780 SHA512 8458abba687135caaefd1cb0adb8af079a2cf94ca484a4bb95ef2b32e00eea46a2c8df7d305d4b0bf7121f46a92ac3a25cd9067e22ad9a314f289f77379a1684
50 changes: 50 additions & 0 deletions app-portage/iwdevtools/iwdevtools-0.5.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit meson optfeature

DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
HOMEPAGE="https://github.com/ionenwks/iwdevtools"
SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
app-misc/pax-utils
app-portage/portage-utils
sys-apps/diffutils
sys-apps/file
sys-apps/portage
sys-apps/util-linux"
BDEPEND="
sys-apps/help2man
test? ( ${RDEPEND} )"

src_configure() {
local emesonargs=(
-Ddocdir=${PF}
-Deprefix="${EPREFIX}"
$(meson_use test)
)
meson_src_configure
}

pkg_postinst() {
optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail

if [[ ! ${REPLACING_VERSIONS} ]]; then
elog "To (optionally) integrate with portage, inspect the .bashrc files installed"
elog "at ${EROOT}/usr/share/${PN}. If not already using a bashrc, you can use"
elog "the example bashrc directly by creating a symlink:"
elog
elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
elog
elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for info on tools."
fi
}

0 comments on commit d1a98a5

Please sign in to comment.