Skip to content

Commit

Permalink
dev-php/xdebug-client: bump to v2.7.0 RC1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.59, Repoman-2.3.12
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Feb 13, 2019
1 parent cbf457b commit d22dac6
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/xdebug-client/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST xdebug-2.5.3.tgz 279085 BLAKE2B cbbfb15e92c3f80cda502340396a6137e2234442fd98bc3fe4b2e08e76cba6292fb5176992aadba7193308ec4c9ab32356922a4416a21b23603e9b48a0d73c06 SHA512 b301a5abb92e123bbe2b36f7838b56d370a0f2c0c4d3c350b5014f4b86d31daa66e9bff995eed67a570558f6a72ca46a097266e6ab94c413f1dcb99c0fbd4f22
DIST xdebug-2.5.5.tgz 279491 BLAKE2B 2492911db7afca2bc96761788c4ec7eac92cb22a6d65b69070b74f702df2bae1ba7dff9f5edfe83542229dbb7ebb3850b6ed1cf19a5e5969413aac3f2d39fc73 SHA512 9faab421bd90c03734c047d8c6dcc021c8bc665eb36781c692f194d04c7dca24fe1eb920ca8dc407e5bf4ae0912c4b917587f940f34b07171a8881d4cf8695d1
DIST xdebug-2.6.1.tgz 283961 BLAKE2B 4478d591591102a9efa248820831e4d43d89eb9b80379c92fe85c888377a31d855ac4ea98c13ad87da68f7e7f659483cfa36fd4651f245d5603fcada2e2fcf73 SHA512 31f26e592b3888d7cc74c6a7c51e0cc1151cf8a32100dda78098fb5b3e307cf8d0445b97247986c75b303a787f89b3937bc042dc52f19ca995753a6843bbd80b
DIST xdebug-2.7.0_rc1.tar.gz 383009 BLAKE2B f8ec78ea1214089fb59cafa8be2f8e4f90c0dbda326a707bd768238da42d23d04cc0dc8e448444e764a1bd474e3bcb98c4b6491d131a28799a01670174e8755a SHA512 38cf59f02953331f16efffa6e6cd9d730fe4b000fe6ae6e364076ae57387b01270b60b0925a516f022bed82165ab448c5c2f52d2108e0231be7a49f1e78a7dbb
40 changes: 40 additions & 0 deletions dev-php/xdebug-client/xdebug-client-2.7.0_rc1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"

MY_PN="xdebug"
MY_PV="${PV/_/}"
MY_PV="${MY_PV/rc/RC}"

inherit autotools

DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)"
HOMEPAGE="https://xdebug.org/"
# Using tarball from GitHub for tests
#SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
SRC_URI="https://github.com/xdebug/xdebug/archive/${MY_PV}.tar.gz -> ${MY_PN}-${PV}.tar.gz"
LICENSE="Xdebug"
SLOT="0"
IUSE="libedit"

S="${WORKDIR}/${MY_PN}-${MY_PV}/debugclient"

DEPEND="libedit? ( dev-libs/libedit ) net-libs/libnsl:0="
RDEPEND="${DEPEND}"

src_prepare() {
default

eautoreconf
}

src_configure() {
econf $(use_with libedit)
}

src_install() {
newbin debugclient xdebug
}

0 comments on commit d22dac6

Please sign in to comment.