forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/gstreamer-editing-services: version bump to 1.6.2
Package-Manager: portage-2.2.26
- Loading branch information
Showing
2 changed files
with
57 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST gstreamer-editing-services-1.4.0.tar.xz 915420 SHA256 cc20b90fb7bcec257b2afda7474664d493b1acece66da675d7df584588808bb3 SHA512 4a3e39089810aa15f2e2e802b1f2a0fcf6f3508a86a5aa8323078334a3f3b427a53e0d3bbb62d42140dc43cbcd9d4985faf0b28edefbcb9814fa76cbb638119b WHIRLPOOL 913149756f5a3dc19e2549014b66484e6390c33d7bfd204899d5d3e9d1f86fe73570ed04548d8ad6700cf9b917344917ae647b0b1d8fb06655dc446e42653e56 | ||
DIST gstreamer-editing-services-1.6.1.tar.xz 1004808 SHA256 f5f7e97db04faeaf6ec941652e75221e244b88e570720e031965d81b759e7bd2 SHA512 d40494a76b411303679b68d69946ff10710f3328b3165175db494b905082598a2df75d89dc3ca21da5cf228c8b53efe9fc498012da937b84710a5177782b0342 WHIRLPOOL 3ccc0aa4c1b4a07baefde351f10f1422148ea4b1029561269e432890793c57e3fcf9b572d07f8b8df5ad77ca93a7f405a1ab4ade883d27009e043ad2cfdcb0f8 | ||
DIST gstreamer-editing-services-1.6.2.tar.xz 1007064 SHA256 d12a174bac7af71f22f9d270aca7bd7abd6478d86247240e5d1e358c645d40c4 SHA512 6191b7527adfa7952af71072948440ce74eff82eee0600412a516ffd6a597cd37f6a0c5bbdf12ee0872059715a6b1c3246101d5e20e497ba751bfe1a1d6e0957 WHIRLPOOL f35f6882221ca5298f2ce37326bc4731781285386db332c8b857f0e6ed8f889ef75210bb6a587dee0cb3d1e9500381df4a4df1232763dc92842f27bf8aaec255 |
56 changes: 56 additions & 0 deletions
56
media-libs/gstreamer-editing-services/gstreamer-editing-services-1.6.2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,56 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
GCONF_DEBUG="no" | ||
|
||
inherit bash-completion-r1 gnome2 | ||
|
||
DESCRIPTION="SDK for making video editors and more" | ||
HOMEPAGE="http://wiki.pitivi.org/wiki/GES" | ||
SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz" | ||
|
||
LICENSE="LGPL-2+" | ||
SLOT="1.0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="+introspection" | ||
|
||
# FIXME: There is something odd with pygobject check for >=4.22, | ||
# check with upstream | ||
COMMON_DEPEND=" | ||
>=dev-libs/glib-2.34:2 | ||
dev-libs/libxml2:2 | ||
>=media-libs/gstreamer-${PV}:1.0[introspection?] | ||
>=media-libs/gst-plugins-base-${PV}:1.0[introspection?] | ||
introspection? ( >=dev-libs/gobject-introspection-0.9.6 ) | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
media-libs/gnonlin:1.0 | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
>=dev-util/gtk-doc-am-1.3 | ||
virtual/pkgconfig | ||
" | ||
# XXX: tests do pass but need g-e-s to be installed due to missing | ||
# AM_TEST_ENVIRONMENT setup. | ||
RESTRICT="test" | ||
|
||
src_configure() { | ||
# gtk is only used for examples | ||
gnome2_src_configure \ | ||
$(use_enable introspection) \ | ||
--disable-examples \ | ||
--without-gtk \ | ||
--with-bash-completion-dir="$(get_bashcompdir)" \ | ||
--with-package-name="GStreamer editing services ebuild for Gentoo" \ | ||
--with-package-origin="https://packages.gentoo.org/package/media-libs/gstreamer-editing-services" | ||
} | ||
|
||
src_compile() { | ||
# Prevent sandbox violations, bug #538888 | ||
# https://bugzilla.gnome.org/show_bug.cgi?id=744135 | ||
# https://bugzilla.gnome.org/show_bug.cgi?id=744134 | ||
addpredict /dev | ||
gnome2_src_compile | ||
} |