Skip to content

Commit

Permalink
dev-util/treecc: EAPI7 bump && improve ebuild.
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/679624
Signed-off-by: Michael Mair-Keimberger <[email protected]>
Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
mm1ke authored and monsieurp committed Apr 9, 2019
1 parent 7f2da4e commit d245362
Showing 1 changed file with 43 additions and 0 deletions.
43 changes: 43 additions & 0 deletions dev-util/treecc/treecc-0.3.10-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DESCRIPTION="Compiler-compiler tool for aspect-oriented programming"
HOMEPAGE="https://www.gnu.org/software/dotgnu"
SRC_URI="https://download.savannah.gnu.org/releases/dotgnu-pnet/${P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~amd64-linux ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~sparc-solaris ~x86 ~x86-linux"
IUSE="doc examples"

DEPEND="doc? ( app-text/texi2html )"

src_compile() {
default

if use doc; then
[[ -f "${S}"/doc/treecc.texi ]] || die "treecc.texi was not generated"
cd "${S}"/doc || die
texi2html -split_chapter "${S}"/doc/treecc.texi \
|| die "texi2html failed"
cd "${S}" || die
fi
}

src_install() {
default

if use examples; then
docinto examples
dodoc examples/README
dodoc examples/{expr_c.tc,gram_c.y,scan_c.l}
fi

if use doc; then
dodoc doc/*.{txt,html}
docinto html
dodoc -r doc/treecc/*.html
fi
}

0 comments on commit d245362

Please sign in to comment.