Skip to content

Commit

Permalink
Merge remote-tracking branch 'github/pr/664'.
Browse files Browse the repository at this point in the history
  • Loading branch information
monsieurp committed Jan 15, 2016
2 parents d1e4107 + 1e8c012 commit d246b17
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libuv/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST libuv-1.5.0.tar.gz 1023438 SHA256 f9c6ad4b7a2c90d93c8e09d2e739bb46d199639c4
DIST libuv-1.6.1.tar.gz 1027771 SHA256 f558ede285878d6a69f6a6d43b5df0241f3c35d62ac989477bdbd418badd83d7 SHA512 3fe53352de312666c02ee6523bd0da3e8a8fb1704eb8c5016490ad3a2275aa1a529123e00173ea626afc284d9863cf5cb5ef4a114655c55925f46632ca5ad0d3 WHIRLPOOL 0ea59068acdc9c9a86521a5ae61148f182d14f39643b1c6df523e79faa249d5a6ab2bbb964bef6a0aff9bbf67d4119a801848421d0029a8f11d1a698213619a4
DIST libuv-1.7.0.tar.gz 1035932 SHA256 27a66f944c8cf1baf0fb53f5cfe11f01035cc80622d8ecc8e18bd1b2ae35ef5f SHA512 01ad2f7aedea5f7076a183fdb0a59f7d091cb7125466e3e243e646f4a88729790a63823d8892e7121cd3a7a293cc9e2b35a6c3e3e89960d4ddfc4bdcd44a0ede WHIRLPOOL 6f6abf004fab3a10b76f16aedd2f73c07a47505e8b850975b315a91c41fed6f5ed58072fe43e1479bf8185d56115ebae93342722fe0c938e86c82a09046b853a
DIST libuv-1.7.5.tar.gz 1041054 SHA256 11d10f12d68fa655fff18c6021e8e45bc610e7baee006f17247b1830ee316093 SHA512 fb79ba02d09460d3f269fb171ea9abe7a32d9ec765672cd7a2e3b93073df3ead2e88742730325adbb83a541c93ffe22574a7bfc92a3c1b7b43f3dfe7f8812c77 WHIRLPOOL 3421214df56d227ab88f1e16d212ef6a38507ed35db743e82f1667ce5817d1ec1b49555ddd78f96678385491e482408bdcd879219e1ccaa802ee978d710aee36
DIST libuv-1.8.0.tar.gz 1048022 SHA256 906e1a5c673c95cb261adeacdb7308a65b4a8f7c9c50d85f3021364951fa9cde SHA512 51d5940873a771278c24a697f0da5c9cb7f42c192daa14254cff9309af600a1b343f1f39272f88d4cd0158f7b15bc966fb7e0b67b9590295fe4d9f0a7c6572b4 WHIRLPOOL ce9c49d5ba646458daa60e3f935d2f53483570d6dc34a8515c875115377929271bbc113c4c382054e9b1dbe4c04e04c2381f90d0776d69b064fb72169b6b4060
44 changes: 44 additions & 0 deletions dev-libs/libuv/libuv-1.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit autotools eutils multilib-minimal

DESCRIPTION="Cross-platform asychronous I/O"
HOMEPAGE="https://github.com/libuv/libuv"
SRC_URI="https://github.com/libuv/libuv/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD BSD-2 ISC MIT"
SLOT="0/1"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="static-libs"
RESTRICT="test"

DEPEND="sys-devel/libtool
virtual/pkgconfig[${MULTILIB_USEDEP}]"

src_prepare() {
echo "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [serial-tests])" \
> m4/libuv-extra-automake-flags.m4 || die

eautoreconf
}

multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
cc_cv_cflags__g=no \
$(use_enable static-libs static)
}

multilib_src_test() {
mkdir "${BUILD_DIR}"/test || die
cp -pPR "${S}"/test/fixtures "${BUILD_DIR}"/test/fixtures || die
default
}

multilib_src_install_all() {
einstalldocs
prune_libtool_files
}

0 comments on commit d246b17

Please sign in to comment.