Skip to content

Commit

Permalink
mail-filter/maildrop: fix building with -fam USE flag
Browse files Browse the repository at this point in the history
Gentoo-Bug: 561184

Package-Manager: portage-2.2.21
  • Loading branch information
erayaslan committed Sep 22, 2015
1 parent 270391b commit d263970
Show file tree
Hide file tree
Showing 2 changed files with 56 additions and 3 deletions.
54 changes: 54 additions & 0 deletions mail-filter/maildrop/files/maildrop-disable-fam.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
--- configure.ac 2005-05-12 16:45:57.000000000 +0200
+++ configure.ac 2005-09-10 20:05:28.000000000 +0200
@@ -145,6 +145,7 @@
--enable-tempdir=.tmp directory for temp files (in user's home dir)
--disable-tempdir disable temp files in home directory (use
the tmpfile function)
+ --disable-fam disable libfam.a for maildir operations
--enable-smallmsg=8192 size of buffer for small messages
--enable-global-timeout=300 global watchdog timer (seconds)
--enable-crlf-term=0 enable <CR><LF> line termination
--- libs/maildir/configure.ac 2005-03-21 13:11:24.000000000 +0100
+++ libs/maildir/configure.ac 2005-09-10 20:10:55.000000000 +0200
@@ -58,26 +58,30 @@
AC_STRUCT_TM

dnl Checks for library functions.
-AC_CHECK_HEADER(fam.h, :, :)
-AC_CHECK_FUNCS(symlink readlink strcasecmp utime utimes)
-AC_CHECK_LIB(fam, FAMOpen, [
+AC_ARG_ENABLE(fam, [ --disable-fam Do not use libfam.a library.])
+if test x$enableval = xyes
+then
+ AC_CHECK_HEADER(fam.h, :, :)
+ AC_CHECK_FUNCS(symlink readlink strcasecmp utime utimes)
+ AC_CHECK_LIB(fam, FAMOpen, [
LIBFAM=-lfam
AC_DEFINE_UNQUOTED(HAVE_FAM,1,
[ Whether libfam.a is available ])

AC_CHECK_HEADER(fam.h, : , [
-AC_MSG_WARN([[The development header files and libraries for fam,]])
-AC_MSG_WARN([[the File Alteration Monitor, are not installed.]])
-AC_MSG_WARN([[You appear to have the FAM runtime libraries installed,]])
-AC_MSG_WARN([[so you need to simply install the additional development]])
-AC_MSG_WARN([[package for your operating system.]])
-AC_MSG_ERROR([[FAM development libraries not found.]]) ]
+ AC_MSG_WARN([[The development header files and libraries for fam,]])
+ AC_MSG_WARN([[the File Alteration Monitor, are not installed.]])
+ AC_MSG_WARN([[You appear to have the FAM runtime libraries installed,]])
+ AC_MSG_WARN([[so you need to simply install the additional development]])
+ AC_MSG_WARN([[package for your operating system.]])
+ AC_MSG_ERROR([[FAM development libraries not found.]]) ]
)
])

-AC_SUBST(LIBFAM)
+ AC_SUBST(LIBFAM)

-echo "$LIBFAM" >maildir.libdeps
+ echo "$LIBFAM" >maildir.libdeps
+fi

AC_CACHE_CHECK([for missing gethostname prototype],maildir_cv_SYS_GETHOSTNAME,

5 changes: 2 additions & 3 deletions mail-filter/maildrop/maildrop-2.8.3.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -50,18 +50,17 @@ src_prepare() {
# Prefer gdbm over berkdb
if use gdbm ; then
use berkdb && elog "Both gdbm and berkdb selected. Using gdbm."
elif use berkdb ; then
epatch "${FILESDIR}"/${PN}-2.5.1-db.patch
fi

if ! use fam ; then
epatch "${FILESDIR}"/${PN}-1.8.1-disable-fam.patch
epatch "${FILESDIR}"/${PN}-disable-fam.patch
fi

# no need to error out if no default - it will be given to econf anyway
sed -i -e \
's~AC_MSG_ERROR(Cannot determine default mailbox)~SPOOLDIR="./.maildir"~' \
"${S}"/libs/maildrop/configure.ac || die "sed failed"

epatch "${FILESDIR}"/${PN}-testsuite-r2.patch
eautoreconf
}
Expand Down

0 comments on commit d263970

Please sign in to comment.