Skip to content

Commit

Permalink
net-vpn/tor: version bump to 0.3.1.1_alpha, new alpha branch
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.1
  • Loading branch information
blueness committed May 24, 2017
1 parent 2655335 commit d263af6
Show file tree
Hide file tree
Showing 3 changed files with 81 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-vpn/tor/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST tor-0.2.9.10.tar.gz 5557586 SHA256 d611283e1fb284b5f884f8c07e7d3151016851848304f56cfdf3be2a88bd1341 SHA512 c18c4faf18406f04165136f0d70e6bc2896f3f02770beadaab5e7a99441d71b897ae3a14a046eaec99a1bd6d8ad7758b28f7d652588842b77621cdc95d4fb7e1 WHIRLPOOL 8a12ab4bd148c6cf57e4e21ae29ccff46b9f687a1646f4453b0ba312b97b78d0c2a428f3178f47e58ec012eb2edce53efff4e07d7f0418d7ccc4ded3856a84a0
DIST tor-0.3.0.6.tar.gz 5779422 SHA256 a3e512e93cb555601fd207d914d7c5fe981d66d6ebb5821ecdf5dea738c2fb14 SHA512 33983f8c0a32fc32e5586cb1da9a99c93b0502eecfb9db289723b275543ea01168cf1dd335e4c1c42ccf7991dd1d584286e764c1881f7d6ece928bbd109781cc WHIRLPOOL 12203d14683f3ac50c2aaa2d85da1758640ce1df8d2d0ebcd3d07411aec41eea3f443dc15c0e7a62dafabea6d1b206d06b39f97cf2b491430abd9adbe19dee77
DIST tor-0.3.0.7.tar.gz 5793734 SHA256 9640c4448ef3cad7237c68ed6984e705db8fb2b9d6bb74c8815d01bb06527d02 SHA512 f6538e6d8dd444d2eb01f0cce48ec51a0e9ab533027d8941f1577f31136782685a4e317ff62bf21dfb52666df8d04f5dc996c5a0ceadccb2ba4fd91653989ccd WHIRLPOOL 34a6e7afb67b676e89d16cbd0805f1d1ed06df5097267e8f26d0a441df269303b9425066ca016b745c83902cc40ba2c964f8a216da76d0cb8560b2b12eb52ee4
DIST tor-0.3.1.1-alpha.tar.gz 5940744 SHA256 c4a7a576df712daf09928daa5c012bb149f301e516e3c5d5f5457c3def63a407 SHA512 fbc5bd1957ff53a25699200f92cde5929db1d37129401f5e65ef0e0601bcfad7fb55d9cc02739bed280055c7be07f0db6417a488d3a9eff8fcc552cfdd454da6 WHIRLPOOL a5b0b5d9875b036a9bb0d839b8d959c64c7094a980fb5d6cb8f167e296c7f9b55da66795c2f04f0f123712dd8f8e52030e1a2655216862a2cf16c03f46dbf355
1 change: 1 addition & 0 deletions net-vpn/tor/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -8,6 +8,7 @@
<use>
<flag name="scrypt">Use <pkg>app-crypt/libscrypt</pkg> for the scrypt algorithm</flag>
<flag name="tor-hardening">Compile tor with hardening on vanilla compilers/linkers</flag>
<flag name="zstd">Use <pkg>app-arch/zstd</pkg> for compression</flag>
<flag name="web">Build a tor2web service instead of a tor client</flag>
</use>
</pkgmetadata>
79 changes: 79 additions & 0 deletions net-vpn/tor/tor-0.3.1.1_alpha.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,79 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

inherit flag-o-matic readme.gentoo-r1 systemd versionator user

MY_PV="$(replace_version_separator 4 -)"
MY_PF="${PN}-${MY_PV}"
DESCRIPTION="Anonymizing overlay network for TCP"
HOMEPAGE="http://www.torproject.org/"
SRC_URI="https://www.torproject.org/dist/${MY_PF}.tar.gz
https://archive.torproject.org/tor-package-archive/${MY_PF}.tar.gz"
S="${WORKDIR}/${MY_PF}"

LICENSE="BSD GPL-2"
SLOT="0"
# We need to keyword app-arch/zstd
#KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
KEYWORDS="~amd64 ~x86"
IUSE="libressl lzma scrypt seccomp selinux systemd tor-hardening test web zstd"

DEPEND="
app-text/asciidoc
dev-libs/libevent[ssl]
sys-libs/zlib
!libressl? ( dev-libs/openssl:0=[-bindist] )
libressl? ( dev-libs/libressl:0= )
lzma? ( app-arch/xz-utils )
scrypt? ( app-crypt/libscrypt )
seccomp? ( sys-libs/libseccomp )
systemd? ( sys-apps/systemd )
zstd? ( app-arch/zstd )"
RDEPEND="${DEPEND}
selinux? ( sec-policy/selinux-tor )"

PATCHES=(
"${FILESDIR}"/${PN}-0.2.7.4-torrc.sample.patch
)

DOCS=( README ChangeLog ReleaseNotes doc/HACKING )

pkg_setup() {
enewgroup tor
enewuser tor -1 -1 /var/lib/tor tor
}

src_configure() {
econf \
--localstatedir="${EPREFIX}/var" \
--enable-system-torrc \
--enable-asciidoc \
--disable-libfuzzer \
$(use_enable scrypt libscrypt) \
$(use_enable seccomp) \
$(use_enable systemd) \
$(use_enable tor-hardening gcc-hardening) \
$(use_enable tor-hardening linker-hardening) \
$(use_enable web tor2web-mode) \
$(use_enable test unittests) \
$(use_enable test coverage)
}

src_install() {
default
readme.gentoo_create_doc

newconfd "${FILESDIR}"/tor.confd tor
newinitd "${FILESDIR}"/tor.initd-r8 tor
systemd_dounit contrib/dist/tor.service

keepdir /var/lib/tor

fperms 750 /var/lib/tor
fowners tor:tor /var/lib/tor

insinto /etc/tor/
newins "${FILESDIR}"/torrc-r1 torrc
}

0 comments on commit d263af6

Please sign in to comment.