Skip to content

Commit

Permalink
media-libs/gstreamer: Fix for >=make-4.3
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/705974
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
SoapGentoo committed Mar 18, 2020
1 parent a21aaac commit d26d946
Show file tree
Hide file tree
Showing 2 changed files with 85 additions and 0 deletions.
84 changes: 84 additions & 0 deletions media-libs/gstreamer/files/gstreamer-1.14.5-make43.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,84 @@
--- a/common/glib-gen.mak
+++ b/common/glib-gen.mak
@@ -1,11 +1,13 @@
# these are the variables your Makefile.am should set
# the example is based on the colorbalance interface

+H := \#
+
#glib_enum_headers=$(colorbalance_headers)
#glib_enum_define=GST_COLOR_BALANCE
#glib_enum_prefix=gst_color_balance

-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
+enum_headers=$(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")

# these are all the rules generating the relevant files
%-marshal.h: %-marshal.list
--- a/common/gst-glib-gen.mak
+++ b/common/gst-glib-gen.mak
@@ -1,14 +1,16 @@
# these are the variables your Makefile.am should set
# the example is based on the colorbalance interface

+H := \#
+
#glib_enum_headers=$(colorbalance_headers)
#glib_enum_define=GST_COLOR_BALANCE
#glib_gen_prefix=gst_color_balance
#glib_gen_basename=colorbalance
#glib_gen_decl_banner=GST_EXPORT
-#glib_gen_decl_include=\#include <gst/foo/foo-prelude.h>
+#glib_gen_decl_include=$(H)include <gst/foo/foo-prelude.h>

-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
+enum_headers=$(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")

# these are all the rules generating the relevant files
$(glib_gen_basename)-marshal.h: $(glib_gen_basename)-marshal.list
--- a/libs/gst/controller/Makefile.in
+++ b/libs/gst/controller/Makefile.in
@@ -17,13 +17,6 @@
# these are the variables your Makefile.am should set
# the example is based on the colorbalance interface

-#glib_enum_headers=$(colorbalance_headers)
-#glib_enum_define=GST_COLOR_BALANCE
-#glib_gen_prefix=gst_color_balance
-#glib_gen_basename=colorbalance
-#glib_gen_decl_banner=GST_EXPORT
-#glib_gen_decl_include=\#include <gst/foo/foo-prelude.h>
-


VPATH = @srcdir@
@@ -550,11 +543,12 @@
gstinterpolationcontrolsource.h \
gstlfocontrolsource.h

+H := \#
glib_enum_define = GST_CONTROLLER
glib_gen_prefix = gst
glib_gen_basename = controller
glib_gen_decl_banner = GST_CONTROLLER_API
-glib_gen_decl_include = \#include <gst/controller/controller-prelude.h>
+glib_gen_decl_include = $(H)include <gst/controller/controller-prelude.h>
built_sources = controller-enumtypes.c
built_headers = controller-enumtypes.h
BUILT_SOURCES = $(built_sources) $(built_headers)
@@ -587,7 +581,14 @@
libgstcontroller_@GST_API_VERSION@_la_LIBADD = $(GST_OBJ_LIBS) $(LIBM)
libgstcontroller_@GST_API_VERSION@_la_LDFLAGS = $(GST_LIB_LDFLAGS) $(GST_ALL_LDFLAGS) $(GST_LT_LDFLAGS)
CLEANFILES = *.gcno *.gcda *.gcov $(BUILT_SOURCES) $(am__append_1)
-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
+
+#glib_enum_headers=$(colorbalance_headers)
+#glib_enum_define=GST_COLOR_BALANCE
+#glib_gen_prefix=gst_color_balance
+#glib_gen_basename=colorbalance
+#glib_gen_decl_banner=GST_EXPORT
+#glib_gen_decl_include=$(H)include <gst/foo/foo-prelude.h>
+enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
@HAVE_INTROSPECTION_TRUE@BUILT_GIRSOURCES = GstController-@[email protected]
@HAVE_INTROSPECTION_TRUE@gir_headers = $(patsubst %,$(srcdir)/%, \
@HAVE_INTROSPECTION_TRUE@ $(libgstcontroller_@GST_API_VERSION@_include_HEADERS)) \
1 change: 1 addition & 0 deletions media-libs/gstreamer/gstreamer-1.14.5.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -37,6 +37,7 @@ DEPEND="${RDEPEND}

PATCHES=(
"${FILESDIR}"/1.14-glib-2.60-tests-compat.patch
"${FILESDIR}"/${PN}-1.14.5-make43.patch # remove when bumping and switching to Meson
)

src_configure() {
Expand Down

0 comments on commit d26d946

Please sign in to comment.