Skip to content

Commit

Permalink
mate-extra/caja-dropbox: 1.12.x vbump, import from project repo
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
NP-Hardass committed Aug 12, 2016
1 parent 8ac8861 commit d286f30
Show file tree
Hide file tree
Showing 2 changed files with 92 additions and 0 deletions.
1 change: 1 addition & 0 deletions mate-extra/caja-dropbox/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST caja-dropbox-1.10.1.tar.xz 306296 SHA256 f171c83cbc162d48fee9dfd67872161db82d93f30a417f9d228402935516f54f SHA512 519f035881197f35b6ff1351cd953c939add62401c3807cfec011697e609766cd19a7effa4cd5978633901e31972f869b0765378893e75fbd6ac202e755e0b94 WHIRLPOOL b3e1a7c045144fee883e35fb2131fc25ddbd9db53a93148e15e9eb827def0e41bc200146e0b243d5f2bd3fe03c5f9eb19ce9d65a0b67c0410b7cf108844b55e6
DIST caja-dropbox-1.12.0.tar.xz 311488 SHA256 027f16529e9fd9139a4fc721aa6971f6ac91f7cf74a7bd22d8a3f2b7315bf247 SHA512 32d8fcd2d2aa4a03a976c7848cd628e240558b802247ad6a36242ea95628aa97088aa55ae6d9c889616910e5fc36e2db6753c4f8854d6f9e626c990469d71223 WHIRLPOOL 6e78e8f216a475ba8594db40ca8bb348276cb47d498993ac01d2a3f5283e90affc2f89c1e5f717874741f09475f84c87aed852d5c82199b8ccf25102f8e85495
91 changes: 91 additions & 0 deletions mate-extra/caja-dropbox/caja-dropbox-1.12.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,91 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python2_7 )
MATE_LA_PUNT="yes"

inherit mate python-single-r1 linux-info user

if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~x86"
fi

DESCRIPTION="Store, Sync and Share Files Online"
LICENSE="GPL-2"
SLOT="0"

IUSE="debug"

RDEPEND="
dev-libs/atk:0
>=dev-libs/glib-2.14:2
dev-python/pygtk:2[${PYTHON_USEDEP}]
dev-python/pygobject:2[${PYTHON_USEDEP}]
>=mate-base/caja-1.6
media-libs/fontconfig:1.0
media-libs/freetype:2
net-misc/dropbox:0
x11-libs/cairo:0
x11-libs/gdk-pixbuf:2
x11-libs/gtk+:2
x11-libs/libXinerama:0
x11-libs/pango:0"

DEPEND="${RDEPEND}
dev-python/docutils:0
virtual/pkgconfig:*"

CONFIG_CHECK="~INOTIFY_USER"

pkg_setup () {
python-single-r1_pkg_setup
check_extra_config
enewgroup dropbox
}

MATE_FORCE_AUTORECONF=true

src_prepare() {
# Use system dropbox.
sed -e "s|~/[.]dropbox-dist|/opt/dropbox|" \
-e 's|\(DROPBOXD_PATH = \).*|\1"/opt/dropbox/dropboxd"|' \
-i caja-dropbox.in || die

# Use system rst2man.
epatch "${FILESDIR}"/${PN}-1.8.0-system-rst2man.patch

mate_src_prepare
}

src_configure() {
mate_src_configure \
--disable-static \
$(use_enable debug)
}

src_install () {
python_fix_shebang caja-dropbox.in

mate_src_install

local extensiondir="$(pkg-config --variable=extensiondir libcaja-extension)"
[ -z ${extensiondir} ] && die "pkg-config unable to get caja extensions dir"

# Strip $EPREFIX from $extensiondir as fowners/fperms act on $ED not $D.
extensiondir="${extensiondir#${EPREFIX}}"
use prefix || fowners root:dropbox "${extensiondir}"/libcaja-dropbox.so
fperms o-rwx "${extensiondir}"/libcaja-dropbox.so
}

pkg_postinst () {
mate_pkg_postinst

elog
elog "Add any users who wish to have access to the dropbox caja"
elog "plugin to the group 'dropbox'. You need to setup a drobox account"
elog "before using this plugin. Visit ${HOMEPAGE} for more information."
elog
}

0 comments on commit d286f30

Please sign in to comment.