Skip to content

Commit

Permalink
net-p2p/syncthing: version bump to 0.12.25 (see bug 583676)
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
djc committed May 21, 2016
1 parent 6a09324 commit d2e4535
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-p2p/syncthing/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST syncthing-0.12.23.tar.gz 4469246 SHA256 e683c784fa423b598920b5c8f29ac6427dfe19000975b85a45f0f03fe2f0e3ff SHA512 f61c2fa6a513e2804f249433eddb3ee7e134a0c144902b56e4be90277f7e74dd163921cbc02b8c0ae284401b15f48f200f3bd75b61528789ea323574bde5e911 WHIRLPOOL bfcac1e2ebf86a6f006254ff740a5b8a093b34fbaf9ff04068ed7b246afc6cc19b6a0438dce43c7acb787a2041a8cca3282317a26372f011eff719815b07d900
DIST syncthing-0.12.24.tar.gz 4469779 SHA256 9faf913b27feb4c532d1febd6e4fc89e60c0b1cfd9aebef4a42851e220227044 SHA512 684c9f863c0427813c32b63aec8cc4d9a1c575dc4b2fb4b989e35b9e1e2b05222edd9935fdf8331b074f9962d4b03d82e67c008e01bf9ce42c01bf68229d46f3 WHIRLPOOL 79680c01eafae7fd853e39dfc9908f61be33627f86e2cf81c7b69dca8b079fa987ef591f1d6f2222b6b3dacdfd8763788706c226c263d7bf0c8919d923565c9b
DIST syncthing-0.12.25.tar.gz 4469275 SHA256 0374721434d0cb8bdd9464f63ff9705fe0ca14ab1e20d916780cb6347c91e72d SHA512 5bdb03ae5f76faddd54304994e04683f2a950419c8b4902553ea83d623976039bc05195f77fe59e2ef19615e91da308adc93b05061265e485a9dc941f2b750d4 WHIRLPOOL e6a10d1142dca73174bd9514526ad8f8357c930aa02fb2a2940adbd690fd209bcad15c3397daabd77052c5962d320665362a86fcafca3d19513ca6d06adcfd37
54 changes: 54 additions & 0 deletions net-p2p/syncthing/syncthing-0.12.25.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

EGO_PN="github.com/syncthing/syncthing"
EGIT_COMMIT=v${PV}

inherit golang-vcs-snapshot systemd user

DESCRIPTION="Open Source Continuous File Synchronization"
HOMEPAGE="https://syncthing.net"
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"

LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~arm"
IUSE=""

DEPEND=""
RDEPEND=""

pkg_setup() {
enewgroup ${PN}
enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
}

src_compile() {
export GOPATH="${S}:$(get_golibdir_gopath)"
cd src/${EGO_PN}
go run build.go -version "v${PV}" -no-upgrade || die "build failed"
}

src_test() {
cd src/${EGO_PN}
go run build.go test || die "test failed"
}

src_install() {
cd src/${EGO_PN}
doman man/*.[157]
dobin bin/*
dodoc README.md AUTHORS CONTRIBUTING.md
systemd_dounit "${S}"/src/${EGO_PN}/etc/linux-systemd/system/${PN}@.service \
"${S}"/src/${EGO_PN}/etc/linux-systemd/system/${PN}-resume.service
systemd_douserunit "${S}"/src/${EGO_PN}/etc/linux-systemd/user/${PN}.service
newconfd "${FILESDIR}/${PN}.confd" ${PN}
newinitd "${FILESDIR}/${PN}.initd" ${PN}
keepdir /var/{lib,log}/${PN}
fowners ${PN}:${PN} /var/{lib,log}/${PN}
insinto /etc/logrotate.d
newins "${FILESDIR}/${PN}.logrotate" ${PN}
}

0 comments on commit d2e4535

Please sign in to comment.