Skip to content

Commit

Permalink
sys-cluster/minikube: Version bump to 0.28.1
Browse files Browse the repository at this point in the history
Fix dependency on libvirt as provided by Holger Hoffstätte in bug 660304

Closes: https://bugs.gentoo.org/660304
Package-Manager: Portage-2.3.43, Repoman-2.3.10
  • Loading branch information
mrueg committed Jul 18, 2018
1 parent ce7501a commit d31542d
Show file tree
Hide file tree
Showing 3 changed files with 49 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-cluster/minikube/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST minikube-0.28.0.tar.gz 20350636 BLAKE2B 002bf7a45483a724d9ebc4f2fa3bad5b9451d9d550211e3e93f8b75555a39358fe11798d0c4b1632c3235ee21e82adc18c9b2f6f4ba9590eb998901f870b7d52 SHA512 bbcc8540b9d64a0ac9da93f912d44c66991d8377fdb96b02a656a8919347b4dd40669c08850582ea54adce6b1ef132c41376f21f4e3cc07e5776df9a3286f4e7
DIST minikube-0.28.1.tar.gz 20075323 BLAKE2B 47444de4c2245d13108b5f98544f5127565ab40178f0bfdda35f710d594b36f8d98dbde8157361172a3486411f7ce32689e87d6b126ba29d21c9061dd0b22fa9 SHA512 80591777cc419ac9dc3b27d444a5d8aa04f2482bd3c47edfbb6b8a74b3552610125dfc5244bbd2659ea46600ed17577e90bcf98e0806d12932dd88c46fd0283a
3 changes: 3 additions & 0 deletions sys-cluster/minikube/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -8,4 +8,7 @@
<upstream>
<remote-id type="github">kubernetes/minikube</remote-id>
</upstream>
<use>
<flag name="libvirt">Build plugin for kvm</flag>
</use>
</pkgmetadata>
45 changes: 45 additions & 0 deletions sys-cluster/minikube/minikube-0.28.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )

inherit python-any-r1 golang-build golang-vcs-snapshot

EGO_PN="k8s.io/minikube"
ARCHIVE_URI="https://github.com/kubernetes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"

DESCRIPTION="Single Node Kubernetes Cluster"
HOMEPAGE="https://github.com/kubernetes/minikube https://kubernetes.io"
SRC_URI="${ARCHIVE_URI}"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="hardened libvirt"

DEPEND="dev-go/go-bindata
${PYTHON_DEPS}
libvirt? ( app-emulation/libvirt[qemu] )"
RDEPEND=">=sys-cluster/kubectl-1.9.4"

RESTRICT="test"

src_prepare() {
default
sed -i -e 's/ -s -w/ -w/' -e 's#.*GOBIN=$(GOPATH)/bin go get github.com/jteeuwen/go-bindata/...##' -e 's#$(GOPATH)/bin/go-bindata#/usr/bin/go-bindata#g' src/${EGO_PN}/Makefile || die
sed -i -e "s/get_commit(), get_tree_state(), get_version()/get_commit(), 'gitTreeState=clean', get_version()/" src/${EGO_PN}/hack/get_k8s_version.py || die
}

src_compile() {
export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -C src/${EGO_PN} $(usex libvirt "out/docker-machine-driver-kvm2" "") out/localkube out/minikube-linux-amd64
}

src_install() {
pushd src/${EGO_PN} || die
newbin out/minikube-linux-amd64 minikube
dobin $(usex libvirt "out/docker-machine-driver-kvm2" "") out/localkube
dodoc -r docs CHANGELOG.md README.md
popd || die
}

0 comments on commit d31542d

Please sign in to comment.