Skip to content

Commit

Permalink
dev-php/pecl-mongodb: bump to v1.9.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.18, Repoman-3.0.3
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Apr 25, 2021
1 parent 983df9a commit d31ba9a
Show file tree
Hide file tree
Showing 2 changed files with 56 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/pecl-mongodb/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST mongodb-1.7.5.tgz 1223892 BLAKE2B c30a217d1170c31be00259f4bb58cfea186947fa0
DIST mongodb-1.8.0.tgz 1292928 BLAKE2B 3bd9e5eb6b981010637b9e478928fa21268e1d1447f3ff345bfdb45c93637990e261c46b2ce09560cd4e284df73494dac210436cf700b588803e4ceffb8dc67c SHA512 7fd54dabde8df9533abd36d159c3da1c2b4606e7788b8a6d41faf83d0710b74885e8bfb4e1f4837a50248f3af1df2e7414b90f99227fc92c9084f779c7e68698
DIST mongodb-1.8.1.tgz 1292453 BLAKE2B 25fe36b7d966a4dcf631764aeb93c09932cc0643e46fe5e594d9223a9d3f099b75211a813114c3e8cd4a1722da774b669ef968fdbb1d4877a81cf1f637890997 SHA512 a80682e3a90ead699a930185c3d10bc3a86b335b45891be6d41ef829fab6f2f2468adb5973735048fa98bb6aaa9c8568ba9f7df5709916d5b6f7676c77188d0c
DIST mongodb-1.9.0.tgz 1300408 BLAKE2B 1cf6a43694e8113df8028c2663db8049421140d53124e6dcf8cb3e42daf961dc6a63cc930c765874eb1ccac13d419980d883e42ba33f3ea389b07ea006217432 SHA512 80ad3caddde045fe5e879167b2b4cfc27bdabf6d3667df4df73f33503c329b0d6bf4da6b287fe454301a9a390434eec19971059c6de8d4c9720a79fe7680366d
DIST mongodb-1.9.1.tgz 1285984 BLAKE2B 7d3dd7635b97d142abdf0882d03f4b7a7b42b9720a8e790dae5d4cfcbee54a2f18d70641851baf9258e59ebe396336ae72956b9f6e09812f017850dbdcc3dd97 SHA512 e1ff9fba2268020862e917a38946a7f5f4cc5caf22b38e9ccf60b491cdee20f55b9643e8904cd934de48d31ca69b1c26dd86454f74572ce977669f908d4ffe51
55 changes: 55 additions & 0 deletions dev-php/pecl-mongodb/pecl-mongodb-1.9.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PHP_EXT_NAME="mongodb"
USE_PHP="php7-3 php7-4 php8-0"

inherit php-ext-pecl-r3

DESCRIPTION="MongoDB database driver for PHP"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="libressl sasl test"

PHP_DEPEND="
php_targets_php7-3? ( dev-lang/php:7.3[json,ssl,zlib] )
php_targets_php7-4? ( dev-lang/php:7.4[json,ssl,zlib] )
php_targets_php8-0? ( dev-lang/php:8.0[ssl,zlib] )"
COMMON_DEPEND="${PHP_DEPEND}
>=dev-libs/libbson-1.17.0
>=dev-libs/mongo-c-driver-1.17.0[sasl?,ssl]
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
sasl? ( dev-libs/cyrus-sasl )"
DEPEND="${COMMON_DEPEND}
test? ( dev-db/mongodb )"
RDEPEND="${COMMON_DEPEND}"
BDEPEND="${PHP_DEPEND}
virtual/pkgconfig"

# No tests on x86 because tests require dev-db/mongodb which don't support
# x86 anymore (bug #645994)
RESTRICT="x86? ( test )
!test? ( test )"

src_configure() {
local PHP_EXT_ECONF_ARGS=(
--enable-mongodb
--with-libbson
--with-libmongoc
--with-mongodb-sasl=$(usex sasl)
)
php-ext-source-r3_src_configure
}

src_test() {
local PORT=27017
mongod --port ${PORT} --bind_ip 127.0.0.1 --nounixsocket --fork \
--dbpath="${T}" --logpath="${T}/mongod.log" || die
php-ext-pecl-r3_src_test
kill $(<"${T}/mongod.lock")
}

0 comments on commit d31ba9a

Please sign in to comment.