forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
kde-plasma/xembed-sni-proxy: 5.24.1 version bump
Signed-off-by: Andreas Sturmlechner <[email protected]>
- Loading branch information
Showing
2 changed files
with
44 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST plasma-workspace-5.23.5.tar.xz 9010724 BLAKE2B 215b862bcf31c4cadc381f80edbc28f6f63d73066dcb43200b1527a07312bda2721ed1cee700d009f4c67add01a1546a7b0cbae944b28dd3ad22e5ae29212bc5 SHA512 5f55137a1c0949ea65e61d8bbf5476a7ba56ef5afd721945c42817030d1c519ada86442426a4eda0dca164cd6676534f710ddc588c319f849415224b6c953099 | ||
DIST plasma-workspace-5.24.0.tar.xz 18458776 BLAKE2B e5d1a3e436beff693c500976891659d97bd90b2317a2c1831770288ddcb51e1732a87b66d26b8739ca844357f75e15ac38e9d4e8c19a1a7c574effe89b625be4 SHA512 ca0b3f37988d0f2b7ff2a0c109dbf8aaf52a1cf175fa27e606709a0f6394dfa3f54b3488cd0eea289cba925b195368bec877c365cfba961c4f0c9a88eeb8af12 | ||
DIST plasma-workspace-5.24.1.tar.xz 18459812 BLAKE2B 6fa5a7d5d70b5e6b1d04e1f3c72965d809f10b34803c23eb37ea59b7a9949ce57e0b563704f94d7073e1863935f01d61e14a5075d0b5a07667cb838bb370bf15 SHA512 b04535ba51f3c6a86c1ea9dd692e5d02b9728614094350c94377b8df5b154886c16d1b1390f45db8d13370cbc443dfb492807a29e28e589157e769463ec13249 |
43 changes: 43 additions & 0 deletions
43
kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.24.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,43 @@ | ||
# Copyright 1999-2022 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
KDE_ORG_NAME="plasma-workspace" | ||
KFMIN=5.90.0 | ||
PVCUT=$(ver_cut 1-3) | ||
QTMIN=5.15.2 | ||
inherit cmake kde.org | ||
|
||
DESCRIPTION="Legacy xembed tray icons support for SNI-only system trays" | ||
HOMEPAGE="https://invent.kde.org/plasma/plasma-workspace/-/blob/master/xembed-sni-proxy/Readme.md" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="5" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86" | ||
|
||
DEPEND=" | ||
>=dev-qt/qtcore-${QTMIN}:5 | ||
>=dev-qt/qtdbus-${QTMIN}:5 | ||
>=dev-qt/qtgui-${QTMIN}:5 | ||
>=dev-qt/qtx11extras-${QTMIN}:5 | ||
>=kde-frameworks/extra-cmake-modules-${KFMIN}:5 | ||
>=kde-frameworks/kwindowsystem-${KFMIN}:5[X] | ||
x11-libs/libxcb | ||
x11-libs/libXtst | ||
x11-libs/xcb-util-image | ||
" | ||
RDEPEND="${DEPEND} | ||
!kde-plasma/xembed-sni-proxy:0 | ||
" | ||
|
||
S="${S}/${PN}" | ||
|
||
PATCHES=( "${FILESDIR}/${PN}-5.20.80-standalone.patch" ) | ||
|
||
src_prepare() { | ||
cmake_src_prepare | ||
|
||
sed -e "/set/s/GENTOO_PV/$(ver_cut 1-3)/" \ | ||
-i CMakeLists.txt || die "Failed to prepare CMakeLists.txt" | ||
} |