Skip to content

Commit

Permalink
app-benchmarks/stress-ng: add 0.15.01
Browse files Browse the repository at this point in the history
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed Dec 13, 2022
1 parent ed21b28 commit d33c2d5
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-benchmarks/stress-ng/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST stress-ng-0.15.00.tar.gz 3743762 BLAKE2B 8f09235129c8ac66ff0a384d6b1c9cbce2673fa6ccafff245676605d3730a81b9fd92f4186a591fbf6975c20c8ac28eb51f3aedaec5a1c74f738bc7030c07706 SHA512 bef6785848c46e39debfc0c4e05e20fe1f443518d619d1ae50b2f9952939e1db964cec0755986a1dd4917e25f979c43d5808b1ff686a4471e8e8be8df9355c05
DIST stress-ng-0.15.01.tar.gz 3758282 BLAKE2B 72eda17c45f232644cb070078df2b2e0221f13762bda0336f3e0ac2f69bd6a1b50f7f94009678943f007f58b76981de8eaa67272170e70c7631b3ba34f9a9dd7 SHA512 c2e062d9b5eb705344c58d39cb2ddb82b45f90dcf32cb343e8178ba7349e734a71e28807b88a7977cbed69c438e8a4f697f91b86245b8b4fe2041c5e0a0ca0e4
56 changes: 56 additions & 0 deletions app-benchmarks/stress-ng/stress-ng-0.15.01.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit linux-info toolchain-funcs

DESCRIPTION="Stress test for a computer system with various selectable ways"
HOMEPAGE="https://github.com/ColinIanKing/stress-ng"
SRC_URI="https://github.com/ColinIanKing/${PN}/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc64 ~riscv ~sparc ~x86"
IUSE="apparmor sctp"

DEPEND="
dev-libs/libaio
dev-libs/libbsd
dev-libs/libgcrypt:0=
sys-apps/attr
sys-apps/keyutils:=
sys-libs/libcap
sys-libs/zlib
virtual/libcrypt:=
apparmor? (
sys-apps/apparmor-utils
sys-libs/libapparmor
)
sctp? ( net-misc/lksctp-tools )
"

RDEPEND="${DEPEND}"

DOCS=( "README.md" "README.Android" "TODO" "syscalls.txt" )

pkg_pretend() {
if use apparmor; then
CONFIG_CHECK="SECURITY_APPARMOR"
check_extra_config
fi
}

src_compile() {
tc-export CC

export MAN_COMPRESS="0"

local myemakeopts=(
HAVE_APPARMOR="$(usex apparmor 1 0)"
HAVE_LIB_SCTP="$(usex sctp 1 0)"
VERBOSE="1"
)

emake "${myemakeopts[@]}"
}

0 comments on commit d33c2d5

Please sign in to comment.