forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-misc/enum: EAPI 7 + SRC_URI move
Closes: https://bugs.gentoo.org/698992 Signed-off-by: Sebastian Pipping <[email protected]> Package-Manager: Portage-2.3.78, Repoman-2.3.16
- Loading branch information
Showing
2 changed files
with
15 additions
and
12 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1 @@ | ||
DIST enum-1.1.tar.bz2 100815 BLAKE2B 921a3c1be5dd91ead83366f1f094c8e50b00e9e58bb3316301a9a162255b55b8104ac09ae5913596c6bfb2b58a3358734950073f87fc8bebfb241a8e6ad0879c SHA512 06396c5286c1e7b725c7cd7952713e21eaf917d586a3f069f2faedbf2fd191f2703ac7e67db563a54978542809552c71eda6a238a22fd2a8928d134ec471e931 | ||
DIST enum-1.1.tar.gz 59849 BLAKE2B fdccdf3a362b3a6f7727c76eb50e4d568b2c6be85fdb62af6f095655865708102e578bb3e4988fdcbb542b2397aff5ad024b89c0cacb120d676aed518bbfcaa5 SHA512 4d2885ea8d3d24d04360b32241517152ab25480c5346917e1bfb483dd0f50ae5a6cb8b4ca3552c04bdb0d5960b1e83502ce4d154fa8316b0e0ff5eae8aac3648 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,34 +1,37 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
EAPI=7 | ||
|
||
inherit autotools | ||
|
||
DESCRIPTION="Replacement for GNU seq and BSD jot" | ||
HOMEPAGE="https://github.com/hartwork/enum" | ||
SRC_URI="https://fedorahosted.org/releases/${PN:0:1}/${PN:1:1}/${PN}/${P}.tar.bz2" | ||
|
||
SRC_URI="https://github.com/hartwork/enum/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
LICENSE="BSD" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
DEPEND="" | ||
DEPEND="app-text/asciidoc" | ||
RDEPEND="" | ||
|
||
DOCS=( ChangeLog ) | ||
|
||
src_prepare() { | ||
default | ||
|
||
# Remove bundled getopt | ||
rm -rv thirdparty || die | ||
|
||
# Workarund automake issues | ||
sed 's,\(AM_INIT_AUTOMAKE(\[\),\1subdir-objects ,' -i configure.ac || die | ||
|
||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
econf \ | ||
--disable-doc-rebuild \ | ||
--enable-doc-rebuild \ | ||
--disable-dependency-tracking | ||
} | ||
|
||
src_install() { | ||
emake DESTDIR="${D}" install | ||
dodoc ChangeLog | ||
} |