Skip to content

Commit

Permalink
dev-libs/rocm-device-libs: Correcting install location according to FHS
Browse files Browse the repository at this point in the history
Signed-off-by: Wilfried Holzke <[email protected]>
Package-Manager: Portage-3.0.8, Repoman-3.0.2
Closes: gentoo#18244
Signed-off-by: Craig Andrews <[email protected]>
  • Loading branch information
justxi authored and candrews committed Nov 13, 2020
1 parent 562741a commit d366c82
Showing 1 changed file with 38 additions and 0 deletions.
38 changes: 38 additions & 0 deletions dev-libs/rocm-device-libs/rocm-device-libs-3.9.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake

if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCm-Device-Libs/"
inherit git-r3
S="${WORKDIR}/${P}/src"
else
SRC_URI="https://github.com/RadeonOpenCompute/ROCm-Device-Libs/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/ROCm-Device-Libs-rocm-${PV}"
KEYWORDS="~amd64"
fi

DESCRIPTION="Radeon Open Compute Device Libraries"
HOMEPAGE="https://github.com/RadeonOpenCompute/ROCm-Device-Libs"

LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"

RDEPEND=">=sys-devel/llvm-roc-${PV}:="
DEPEND="${RDEPEND}"

src_prepare() {
sed -e "s:amdgcn/bitcode:lib/amdgcn/bitcode:" -i "${S}/cmake/OCL.cmake" || die
sed -e "s:amdgcn/bitcode:lib/amdgcn/bitcode:" -i "${S}/cmake/Packages.cmake" || die
cmake_src_prepare
}

src_configure() {
local mycmakeargs=(
-DLLVM_DIR="${EPREFIX}/usr/lib/llvm/roc/lib/cmake/llvm"
)
cmake_src_configure
}

0 comments on commit d366c82

Please sign in to comment.