Skip to content

Commit

Permalink
dev-db/percona-xtrabackup: bump to v8.0.23-16
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.17, Repoman-3.0.2
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Mar 23, 2021
1 parent 1a21a9a commit d377e5b
Show file tree
Hide file tree
Showing 2 changed files with 87 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/percona-xtrabackup/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -6,3 +6,4 @@ DIST percona-xtrabackup-2.4.20.tar.gz 59782001 BLAKE2B 25deaa3044d89d6f884734bba
DIST percona-xtrabackup-2.4.21.tar.gz 61901220 BLAKE2B 77245818015d4e9c22d05cfeb254ff570ab490c43f9d2fd0e1c499e1e3fefb143b4659fb929740a563e2344b3cd7dfb408931c6d24b277f6df06886dfa83126e SHA512 8b14ef4620fdf836a090d07e5aeb78141eacf081a2cf1069d91af1ba5206e36e3e195f8acb06609f334661d6ad27937b31e997b0f1aabb9cef612d35fabd0284
DIST percona-xtrabackup-8.0.13.tar.gz 272887474 BLAKE2B d0ac4c602c7c3197ca0a7c361f9658bd2da00bdac5c6dc0a4d56b92e04e4e6c86f22b70e7cf2b375f121983ea7f134edae93116c91945b2c3314a51565033ae5 SHA512 b1fdb0dea1c8b6e39b5451153f01c8ce0dcf411fd88fe8f9f686e562e0950ff9270a39574230ada928b734cc8bb4517da0f01310e75d5c9beba0e35cfeaa11ff
DIST percona-xtrabackup-8.0.22-15.tar.gz 294237178 BLAKE2B 819d7594bc41e0adc1e6f2632e6ad50de7a2416c7577f48ea83948bed1b14c0c552c4c44597c84c86fa292bcbbaace185978956acdc39070f81ede6701f4af52 SHA512 f5295e2f1e3ee71931295f89dbd708eed936c4912ab3b6c122eb63795ee2e5154011ddf95cfad005a89c7f086f087f7fb19068d098b49202c697a95b58ee7672
DIST percona-xtrabackup-8.0.23-16.tar.gz 288261551 BLAKE2B ca82bfcac881cd1d9d3a1d0ea4647d809030b617cc8605f26f1378fba74f106b522447fc67be3968fe72bd8c6bd9fa64ba1943d8379c11f241178aa232680f06 SHA512 11927649ab2a25dbfc5268ab2196dbdd2b102229728a41dc61995aec92a133718c0bf79d3fe15ea91e0917cd4201bba806647d259a6aa0fc7b59ff8bd533e810
86 changes: 86 additions & 0 deletions dev-db/percona-xtrabackup/percona-xtrabackup-8.0.23.16.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,86 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

CMAKE_MAKEFILE_GENERATOR="emake"

inherit cmake flag-o-matic

MY_BOOST_VERSION="1.73.0"
MY_PV=$(ver_rs 3 '-')
MY_PV="${MY_PV//_pre*}"
MY_PN="Percona-XtraBackup"
MY_P="${PN}-${MY_PV}"
MY_MAJOR_PV=$(ver_cut 1-2)

DESCRIPTION="Hot backup utility for MySQL based servers"
HOMEPAGE="https://www.percona.com/software/mysql-database/percona-xtrabackup"
SRC_URI="https://www.percona.com/downloads/${MY_PN}-${MY_MAJOR_PV}/${MY_PN}-${MY_PV}/source/tarball/${PN}-${MY_PV}.tar.gz
https://dl.bintray.com/boostorg/release/${MY_BOOST_VERSION}/source/boost_$(ver_rs 1- _ ${MY_BOOST_VERSION}).tar.bz2
"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"

DEPEND="
app-arch/lz4:0=
app-editors/vim-core
dev-libs/icu:=
dev-libs/libaio
dev-libs/libedit
dev-libs/libev
dev-libs/libevent:0=
dev-libs/libgcrypt:0=
dev-libs/libgpg-error
dev-libs/openssl:0=
dev-libs/protobuf:=
dev-libs/rapidjson
dev-libs/re2:=
dev-python/sphinx
net-misc/curl
sys-libs/zlib:="

RDEPEND="
${DEPEND}
!dev-db/percona-xtrabackup-bin
dev-perl/DBD-mysql"

PATCHES=(
"${FILESDIR}"/${PN}-8.0.22-remove-rpm.patch
"${FILESDIR}"/${PN}-8.0.22-fix-building-against-ICU-68.patch
)

S="${WORKDIR}/percona-xtrabackup-${MY_PV}"

src_configure() {
CMAKE_BUILD_TYPE="RelWithDebInfo"

local mycmakeargs=(
-DCMAKE_C_FLAGS_RELWITHDEBINFO=-DNDEBUG
-DCMAKE_CXX_FLAGS_RELWITHDEBINFO=-DNDEBUG
-DBUILD_SHARED_LIBS=OFF
-DCOMPILATION_COMMENT="Gentoo Linux ${PF}"
-DINSTALL_PLUGINDIR=$(get_libdir)/${PN}/plugin
-DWITH_BOOST="${WORKDIR}/boost_$(ver_rs 1- _ ${MY_BOOST_VERSION})"
-DWITH_MAN_PAGES=ON
-DWITH_SYSTEM_LIBS=ON
)

cmake_src_configure
}

src_install() {
local p="${BUILD_DIR}/storage/innobase/xtrabackup"

dobin "${p}"/xbcloud_osenv
dobin "${BUILD_DIR}"/runtime_output_directory/{xbcloud,xbcrypt,xbstream,xtrabackup}

# cannot use dolib.so because helper would append libdir to target dir
insinto /usr/$(get_libdir)/${PN}/plugin
insopts -m 0755
doins "${BUILD_DIR}"/plugin_output_directory/{keyring_file.so,keyring_vault.so}

doman "${p}"/doc/source/build/man/*
}

0 comments on commit d377e5b

Please sign in to comment.