Skip to content

Commit

Permalink
dev-python/apsw: version bump to 3.15.1_p1
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Nov 30, 2016
1 parent 70447b4 commit d37f0f3
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/apsw/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST apsw-3.11.1_p1.zip 679045 SHA256 92685d555bb5bdbf5ec85563cd826f76630c33a589
DIST apsw-3.13.0_p1.zip 692414 SHA256 1f8e337f88befb609427d468ee87c99da0b9477a9cdfd02423a728d0ed10d576 SHA512 6efa73eacc413c7b1ed4a8fd3a510d7c86cab85dee4f89055101154a0e3a00adee6fa79fd44dff25bc4b3075adaa4e6f56270336bf73141eeffa340d8047c3e4 WHIRLPOOL 54a69ce647047ffb885f3d8da9974a19b88cc99140b380c406069e86e92cd6ef5fc9d091de21c7f30afffe2fa0f5aa4b4af307ea063a1783f0bad4fa40cff1be
DIST apsw-3.14.1_p1.zip 693104 SHA256 e76f955bfa22bda7e46423218ba7ac8f460af3ebfe02faedd938600262c6798e SHA512 1f2a8c47a89656e3c3e2320185b0020ffd414aa28c9b9629b0504767b15c5ccded0e896ddc514f048ad9e0a5f262fbb6b945788ff215504fe1a72395a564becf WHIRLPOOL 0731ed3b38fe2c59b1dbdee9fa336bad49c1d1e69e8fb05383e50e2cbff05ce1798319c12f2ee00997c6010fb50441db8e1caf9781ca2b496d939e6fa17f24e4
DIST apsw-3.15.0_p1.zip 690750 SHA256 cac4d2afad9661892aafa46dcba19a6982f3fc56be7a48322e75660c4662b3d5 SHA512 eca4c5264334009feec56bbb25ff4285936ab4690e49309fc82abfa6e6a7ebfa62bbb4a773024f93f99f6fced7651ede2a431c118eca9918b458e90f6e626ae8 WHIRLPOOL 1a269548aae2396a0922602cd99f93488c5fdf3e1ad60ef4eb0111c3666d23952c8e613ccf1f93637e2f56730b8382f744188dd87983d76e4b8a86bc28fa0f8b
DIST apsw-3.15.1_p1.zip 690913 SHA256 8122431b7d8d698221e2544fefa7be9d50d440e183a52d7fad9ccc6cc8032a8b SHA512 4d0e83e2b956b0333a21c23fe1c44fc39f1dc9ef66c79e4c22de897afa5e2d7444ba35f04426255b3f2392d17a41d54d3cec48737f6de0fad151adac8ee568f8 WHIRLPOOL 1b338b54c382154326c6d4af1900203d18e296d837f2405973a118c4d0d04ee7cc36afdd354b177fd38d196c5cc8cb5c2dd5643d63eb317049893830d50c9c9b
43 changes: 43 additions & 0 deletions dev-python/apsw/apsw-3.15.1_p1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5} )

inherit distutils-r1 flag-o-matic

MY_PV=${PV/_p/-r}
MY_P=${PN}-${MY_PV}

DESCRIPTION="APSW - Another Python SQLite Wrapper"
HOMEPAGE="https://github.com/rogerbinns/apsw/"
SRC_URI="https://github.com/rogerbinns/apsw/releases/download/${MY_PV}/${MY_P}.zip -> ${P}.zip"

LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
IUSE="doc"

RDEPEND=">=dev-db/sqlite-${PV%_p*}"
DEPEND="${RDEPEND}
app-arch/unzip"

S=${WORKDIR}/${MY_P}

PATCHES=( "${FILESDIR}/${PN}-3.6.20.1-fix_tests.patch" )

python_compile() {
python_is_python3 || append-cflags -fno-strict-aliasing
distutils-r1_python_compile --enable=load_extension
}

python_test() {
"${PYTHON}" setup.py build_test_extension || die "Building of test loadable extension failed"
"${PYTHON}" tests.py -v || die "Tests failed under ${EPYTHON}"
}

python_install_all() {
use doc && local HTML_DOCS=( doc/. )
distutils-r1_python_install_all
}

0 comments on commit d37f0f3

Please sign in to comment.