Skip to content

Commit

Permalink
dev-util/artifactory-bin: version bump - 5.5.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
austin987 committed Oct 10, 2017
1 parent d151daa commit d38f587
Show file tree
Hide file tree
Showing 2 changed files with 111 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/artifactory-bin/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST artifactory-4.16.1.zip 41489457 SHA256 f3715397f7e792de76cfecfe2b41ebbf5454
DIST artifactory-5.3.2.zip 45729254 SHA256 e086a067ad191859cd0a0c996313cf5c7386e6ee892b55697c27b0f42ae2bc14 SHA512 60fbbed97c9915ed4a7627a3b893fa6c5bcec695932415d3102b9788ba6182c8cef937ad48639d4398a682ab2f517771c3dcda9306842e4202bbd45ab4768f1d WHIRLPOOL bf3b31f7a1989ddb90b03396172eeac37dc5230c4bbcc99b54c66326e5d52e26dbb83003824647c6e89926049c31b9644212aee183fa24db7475831dda0ceaec
DIST artifactory-5.4.4.zip 76841935 SHA256 bf2198a0fefe818fe412579dd008f2a24dc065780da4c9657a923363c70a0a3d SHA512 f949e4c2ecaaf4581bc2e96058403684cab09f10b0bec512eda9b65bb41577a792b08d05f7a16e0e7f1614567dc9b0d1d59bb3c6ad6a4dafeb0c054a3add09a8 WHIRLPOOL c0c27a0ce5b0035d9266b6af4316044cf1aed361dbe0f7aaf66844015a70678e92bb0c6a13330ffd8f5a05903f66a82b48995605c272ba3950a19aa47d1fc85d
DIST artifactory-5.4.6.zip 76857888 SHA256 43fb4b14ad5350daa200e0282a36903495505ccb536b5f0ac7d7b5487dcdfca6 SHA512 08d7895dc823e61be83026d31eea387eb914f17cb2f13b03d5314c6473f30de9279d230d242d8160dba0d3c8f6981b25b5ad46f52ad12d1c39ee820ac7a676fe WHIRLPOOL dcc86f1326011bb89c3e65a420c9f9ad02afea3a144b4b5eac8b617bec7dbb72256a6ac1f67d2bae034897bd02801b24e59746d1543e957d8e595d7ea83a4964
DIST artifactory-5.5.1.zip 77406287 SHA256 e4180ec0c6a4ed9bc8da1287ac1d661c421d59bc11e56d47dd106ead31d8a44f SHA512 7327135be0c2a08dd97c575b05be1c3e4be99b38354864313d201334d3276912bcff0c6b0743fb83a2433a82fc8fcf4ec43e98f4183287fc34f1807342abedf8 WHIRLPOOL fcd3c368eafbd956eba15ae1c5cd7362d423acb0e6a0b529c8b7088ff2ec1437e02dd5b5b277c71d7bbba788db11963c2eed784ce95ba1dcb550fd41a0224722
110 changes: 110 additions & 0 deletions dev-util/artifactory-bin/artifactory-bin-5.5.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,110 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

# Using a binary ebuild until a source ebuild is doable.
# This was previously blocked by two major bugs upstream:
# A lack of documented build instructions - https://www.jfrog.com/jira/browse/RTFACT-8960
# A lack of source releases - https://www.jfrog.com/jira/browse/RTFACT-8961
# Upstream now releases source and instructions (yay!), but most of artifactory's
# dependencies are not in portage yet.

EAPI=6

inherit user

MY_P="${P/-bin}"
MY_PN="${PN/-bin}"
MY_PV="${PV/-bin}"

DESCRIPTION="The world's most advanced repository manager for maven"
HOMEPAGE="http://www.jfrog.org/products.php"
SRC_URI="https://bintray.com/artifact/download/jfrog/artifactory/jfrog-artifactory-oss-${MY_PV}.zip -> ${MY_P}.zip"

LICENSE="AGPL-3+"
SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE="ssl"

RDEPEND=">=virtual/jre-1.8"
DEPEND=">=virtual/jdk-1.8
app-arch/unzip"

S="${WORKDIR}/${MY_PN}-oss-${MY_PV}"

pkg_setup() {
enewgroup artifactory
enewuser artifactory -1 /bin/sh -1 artifactory
}

limitsdfile=40-${MY_PN}.conf

print_limitsdfile() {
printf "# Start of ${limitsdfile} from ${P}\n\n"
printf "@${MY_PN}\t-\tnofile\t32000\n"
printf "\n# End of ${limitsdfile} from ${P}\n"
}

src_prepare() {
default

if use ssl ; then
cp "${FILESDIR}/artifactory.xml" tomcat/conf/Catalina/localhost/artifactory.xml || die
cp "${FILESDIR}/server.xml" tomcat/conf/server.xml || die
fi

# Reverse https://www.jfrog.com/jira/browse/RTFACT-7123
sed -i -e "s%artifactory.repo.global.disabled=true%artifactory.repo.global.disabled=false%g;" \
etc/artifactory.system.properties || die

# See FIXME in src_install(), this can probably go away,
# but catalina.sh may need to be fixed for that:
sed -i -e "s%/etc/opt/jfrog/artifactory/default%/etc/conf.d/${MY_PN}%g;" \
misc/service/setenv.sh || die

einfo "Generating ${limitsdfile}"
print_limitsdfile > "${S}/${limitsdfile}"
}

src_install() {
local ARTIFACTORY_HOME="/opt/artifactory"
local TOMCAT_HOME="${ARTIFACTORY_HOME}/tomcat"

insinto ${ARTIFACTORY_HOME}
doins -r etc logs misc tomcat webapps

dodir /etc/opt/jfrog
dosym ${ARTIFACTORY_HOME}/etc /etc/opt/jfrog/artifactory

dosym ${ARTIFACTORY_HOME}/logs /var/log/artifactory

exeinto ${ARTIFACTORY_HOME}/bin
doexe bin/*

# FIXME: this is called by catalina.sh (it echoes the variables before starting
# artifactory, as well as makes sure log dir, etc. exists). Those directories
# could probably be moved to the ebuild and the script removed from catalina.sh
# without consequence (and quieter starts). Would need to check if CATALINA_*
# variables are actually used anywhere (from reading code don't appear to be
# actually needed)
exeinto ${TOMCAT_HOME}/bin
doexe misc/service/setenv.sh
doexe tomcat/bin/*

keepdir ${ARTIFACTORY_HOME}/backup
keepdir ${ARTIFACTORY_HOME}/data
keepdir ${ARTIFACTORY_HOME}/run
keepdir ${ARTIFACTORY_HOME}/work
keepdir ${TOMCAT_HOME}/logs/catalina
keepdir ${TOMCAT_HOME}/temp
keepdir ${TOMCAT_HOME}/work
keepdir /var/opt/jfrog/artifactory/run

newconfd "${FILESDIR}/confd" ${MY_PN}
newinitd "${FILESDIR}/initd-r3" ${MY_PN}

fowners -R artifactory:artifactory ${ARTIFACTORY_HOME}
fperms -R u+w ${TOMCAT_HOME}/work

insinto /etc/security/limits.d
doins "${S}/${limitsdfile}"
}

0 comments on commit d38f587

Please sign in to comment.