Skip to content

Commit

Permalink
net-misc/i2pd: fix static build #591334
Browse files Browse the repository at this point in the history
  • Loading branch information
khumarahn authored and blueness committed Aug 16, 2016
1 parent 338af35 commit d3e0e61
Show file tree
Hide file tree
Showing 2 changed files with 27 additions and 1 deletion.
25 changes: 25 additions & 0 deletions net-misc/i2pd/files/i2pd-2.9.0-static.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
From 2e74d91ddc1a776692dd7398e0126a6bd1f2a92a Mon Sep 17 00:00:00 2001
From: Jeff Becker <[email protected]>
Date: Tue, 16 Aug 2016 10:25:56 -0400
Subject: [PATCH] try fixing https://github.com/PurpleI2P/i2pd/issues/612

---
build/CMakeLists.txt | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/build/CMakeLists.txt b/build/CMakeLists.txt
index 7f9b8c6..99d6a5a 100644
--- a/build/CMakeLists.txt
+++ b/build/CMakeLists.txt
@@ -369,7 +369,10 @@ if (WITH_BINARY)
if (MSYS OR MINGW)
set (MINGW_EXTRA -lws2_32 -lmswsock -liphlpapi )
endif ()
- target_link_libraries( "${PROJECT_NAME}" libi2pd i2pdclient ${DL_LIB} ${Boost_LIBRARIES} ${OPENSSL_LIBRARIES} ${ZLIB_LIBRARY} ${CMAKE_THREAD_LIBS_INIT} ${MINGW_EXTRA} )
+ if (WITH_STATIC)
+ set(DL_LIB ${CMAKE_DL_LIBS})
+ endif()
+ target_link_libraries( "${PROJECT_NAME}" libi2pd i2pdclient ${DL_LIB} ${Boost_LIBRARIES} ${OPENSSL_LIBRARIES} ${ZLIB_LIBRARY} ${CMAKE_THREAD_LIBS_INIT} ${MINGW_EXTRA} ${DL_LIB})

install(TARGETS "${PROJECT_NAME}" RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR} COMPONENT Runtime)
set (APPS "\${CMAKE_INSTALL_PREFIX}/bin/${PROJECT_NAME}${CMAKE_EXECUTABLE_SUFFIX}")
Original file line number Diff line number Diff line change
Expand Up @@ -35,7 +35,8 @@ CMAKE_USE_DIR="${S}/build"

DOCS=( README.md docs/i2pd.conf debian/tunnels.conf debian/subscriptions.txt )

PATCHES=( "${FILESDIR}/${PN}-2.5.1-fix_installed_components.patch" )
PATCHES=( "${FILESDIR}/i2pd-2.9.0-static.patch" \
"${FILESDIR}/${PN}-2.5.1-fix_installed_components.patch" )

src_configure() {
mycmakeargs=(
Expand Down

0 comments on commit d3e0e61

Please sign in to comment.