forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-libs/xapian-bindings: version bump to 1.2.24
Package-Manager: portage-2.2.28
- Loading branch information
Showing
2 changed files
with
204 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,5 @@ | ||
DIST xapian-bindings-1.2.22.tar.xz 844040 SHA256 b15ca7984980a1d2aedd3378648ef5f3889cb39a047bac1522a8e5d04f0a8557 SHA512 0eec204ebb92f1230b9dbd080ad2b56ea5fa8e6170eb4354556e5790c7a7da7ba4c8475aaf86fb8f10f102a461d91590184271220626315f55c0631e73e122e0 WHIRLPOOL 05ac5b31d73f9de0c101da832ef289f6a505baa68216eba6fa0cf80df1709feef7e42c7b8f4cf9af35f775e8514c6d4b944c2acebffff10bc558a83305a637ce | ||
DIST xapian-bindings-1.2.23.tar.xz 885888 SHA256 19b4b56c74863c51733d8c2567272ef7f004b898cf44016711ae25bc524b2215 SHA512 4be9d103a4073a08d2481e9ddc347156d4028a1517f313861ad3664e6103e052dc1a0d07a992da3ca02599505c002d09d77c4fd886c144918aab72977e69994c WHIRLPOOL 1323e51dcd8f18f573f9338d9a013bfd370870c1fd2c0b0e3ff9d1f6b3b9154a0512d7442d7c7b1b00a70757faa218e8894a0f4fe56da88bca12ba2259cd35de | ||
DIST xapian-bindings-1.2.24.tar.xz 886148 SHA256 0c2a0df0a4616e2bd8e578d372c9bb4684780573abebbd1ac515502177229965 SHA512 aaedac02ec9fb192ef8b45b07bef5584bc60aff7068c2e3fa0008430ed8296a653780cad04176431d81fe014802df333a3090469dce63204923eead15e6bbaef WHIRLPOOL 996b960727a79dbe669ae8139863c3896c6efdbe781177098d00960982b86a43739433c69db32e62b6660dd4751736d859f5d950d26d6b635c310c35d75a8a0f | ||
DIST xapian-bindings-1.3.7.tar.xz 1021176 SHA256 f014bb0281fdaa08fd9293ee187af0c2165f4fd2de91a67b76d9327b64677717 SHA512 3dc7eac68c4f3010e5cb831b4baad7bea4d47e0a8dc492ac16f2437057da351caad008aa7bcf3f2bbdaffda7d2524e8b5a945b651dc02deadeb110073ef06ad8 WHIRLPOOL f68a81a37b9c298ad6b061f597806b0823ba01ee02c0921e90988c984ac2f60ec0cb09dba8bdecb43c412517eebd72490196923db474e5362d17c47af4b4fdd2 | ||
DIST xapian-bindings-1.4.0.tar.xz 1021244 SHA256 3aec7a009d0bf0b95968420bf68683176c05d63140eaf1cf265d39afe8fa6253 SHA512 16523be4f2cd576819771e387d469c91cd03b27522808eebc9275ac3281e55c5d40a5c620ad37f96c2dbc89cc2b13808579e29d737eb63584b8c209597b0f7ce WHIRLPOOL 26a31b8a2ca8bd08a45e79fb5f926e917db8e65d8ee1f07c9291c573b8efa647c9ff7bc1c6c3130ae69538ffa1789a0ad60d940f00b758066e55f4835ec20433 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,203 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
|
||
PYTHON_COMPAT=( python2_7 ) | ||
PYTHON_REQ_USE="threads" | ||
|
||
USE_PHP="php5-5 php5-6" | ||
|
||
PHP_EXT_NAME="xapian" | ||
PHP_EXT_INI="yes" | ||
PHP_EXT_OPTIONAL_USE="php" | ||
|
||
#mono violates sandbox, we disable it until we figure this out | ||
#inherit java-pkg-opt-2 mono-env php-ext-source-r2 python | ||
inherit java-pkg-opt-2 php-ext-source-r2 python-r1 toolchain-funcs | ||
|
||
DESCRIPTION="SWIG and JNI bindings for Xapian" | ||
HOMEPAGE="http://www.xapian.org/" | ||
SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${P}.tar.xz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86" | ||
#IUSE="java lua mono perl php python ruby tcl" | ||
#REQUIRED_USE="|| ( java lua mono perl php python ruby tcl )" | ||
IUSE="java lua perl php python ruby tcl" | ||
REQUIRED_USE="|| ( java lua perl php python ruby tcl )" | ||
|
||
COMMONDEPEND="dev-libs/xapian:0/1.2.22 | ||
lua? ( dev-lang/lua:0 ) | ||
perl? ( dev-lang/perl:= ) | ||
ruby? ( dev-lang/ruby:= ) | ||
tcl? ( >=dev-lang/tcl-8.1:0= )" | ||
# mono? ( >=dev-lang/mono-1.0.8 ) | ||
DEPEND="${COMMONDEPEND} | ||
virtual/pkgconfig | ||
java? ( >=virtual/jdk-1.3 )" | ||
RDEPEND="${COMMONDEPEND} | ||
java? ( >=virtual/jre-1.3 )" | ||
|
||
pkg_setup() { | ||
java-pkg-opt-2_pkg_setup | ||
} | ||
|
||
src_unpack() { | ||
default | ||
} | ||
|
||
src_prepare() { | ||
java-pkg-opt-2_src_prepare | ||
if use java; then | ||
sed \ | ||
-e 's/$(JAVAC)/$(JAVAC) $(JAVACFLAGS)/' \ | ||
-i java{/,/org/xapian/errors/,/org/xapian/}Makefile.in || die "sed failed" | ||
fi | ||
|
||
if use python; then | ||
sed \ | ||
-e 's:\(^pkgpylib_DATA = xapian/__init__.py\).*:\1:' \ | ||
-e 's|\(^xapian/__init__.py: modern/xapian.py\)|\1 xapian/_xapian.so|' \ | ||
-i python/Makefile.in || die "sed failed" | ||
fi | ||
} | ||
|
||
src_configure() { | ||
if use java; then | ||
CXXFLAGS="${CXXFLAGS} $(java-pkg_get-jni-cflags)" | ||
fi | ||
|
||
if use perl; then | ||
export PERL_ARCH="$(perl -MConfig -e 'print $Config{installvendorarch}')" | ||
export PERL_LIB="$(perl -MConfig -e 'print $Config{installvendorlib}')" | ||
fi | ||
|
||
if use lua; then | ||
export LUA_LIB="$($(tc-getPKG_CONFIG) --variable=INSTALL_CMOD lua)" | ||
fi | ||
|
||
econf \ | ||
$(use_with java) \ | ||
$(use_with lua) \ | ||
$(use_with perl) \ | ||
$(use_with php) \ | ||
$(use_with python) \ | ||
$(use_with ruby) \ | ||
$(use_with tcl) | ||
# $(use_with mono csharp) \ | ||
|
||
# PHP and Python bindings are built/tested/installed manually. | ||
sed -e "/SUBDIRS =/s/ php//" -i Makefile || die "sed Makefile" | ||
sed -e "/SUBDIRS =/s/ python//" -i Makefile || die "sed Makefile" | ||
} | ||
|
||
src_compile() { | ||
default | ||
|
||
if use php; then | ||
local php_slot | ||
for php_slot in $(php_get_slots); do | ||
cp -r php php-${php_slot} | ||
emake -C php-${php_slot} \ | ||
PHP="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php" \ | ||
PHP_CONFIG="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" \ | ||
PHP_EXTENSION_DIR="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --extension-dir)" \ | ||
PHP_INC="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --includes)" | ||
done | ||
fi | ||
|
||
if use python; then | ||
python_copy_sources | ||
# building() { | ||
# emake -C python \ | ||
# PYTHON="$(PYTHON)" \ | ||
# PYTHON_INC="$(python_get_includedir)" \ | ||
# PYTHON_LIB="$(python_get_libdir)" \ | ||
# PYTHON_SO="$("$(PYTHON)" -c 'import distutils.sysconfig; print(distutils.sysconfig.get_config_vars("SO")[0])')" \ | ||
# pkgpylibdir="$(python_get_sitedir)/xapian" | ||
# } | ||
building() { | ||
emake -C python \ | ||
PYTHON_INC="$(python_get_includedir)" \ | ||
pkgpylibdir="$(python_get_sitedir)/xapian" | ||
VERBOSE="1" | ||
} | ||
python_foreach_impl building | ||
fi | ||
} | ||
|
||
src_test() { | ||
default | ||
|
||
if use php; then | ||
local php_slot | ||
for php_slot in $(php_get_slots); do | ||
emake -C php-${php_slot} \ | ||
PHP="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php" \ | ||
PHP_CONFIG="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" \ | ||
PHP_EXTENSION_DIR="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --extension-dir)" \ | ||
PHP_INC="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --includes)" \ | ||
check | ||
done | ||
fi | ||
|
||
if use python; then | ||
testing() { | ||
emake -C python \ | ||
PYTHON_INC="$(python_get_includedir)" \ | ||
pkgpylibdir="$(python_get_sitedir)/xapian" \ | ||
VERBOSE="1" \ | ||
check | ||
} | ||
python_foreach_impl testing | ||
fi | ||
} | ||
|
||
src_install () { | ||
emake DESTDIR="${D}" install | ||
|
||
if use java; then | ||
java-pkg_dojar java/built/xapian_jni.jar | ||
# TODO: make the build system not install this... | ||
java-pkg_doso "${D}/${S}/java/built/libxapian_jni.so" | ||
rm "${D}/${S}/java/built/libxapian_jni.so" | ||
rmdir -p "${D}/${S}/java/built" | ||
rmdir -p "${D}/${S}/java/native" | ||
fi | ||
|
||
if use php; then | ||
local php_slot | ||
for php_slot in $(php_get_slots); do | ||
emake DESTDIR="${D}" -C php-${php_slot} \ | ||
PHP="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php" \ | ||
PHP_CONFIG="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" \ | ||
PHP_EXTENSION_DIR="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --extension-dir)" \ | ||
PHP_INC="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --includes)" \ | ||
install | ||
done | ||
|
||
php-ext-source-r2_createinifiles | ||
fi | ||
|
||
if use python; then | ||
installation() { | ||
emake -C python \ | ||
DESTDIR="${D}" \ | ||
PYTHON_INC="$(python_get_includedir)" \ | ||
pkgpylibdir="$(python_get_sitedir)/xapian" \ | ||
VERBOSE="1" \ | ||
install | ||
} | ||
python_foreach_impl installation | ||
fi | ||
|
||
# For some USE combinations this directory is not created | ||
if [[ -d "${D}/usr/share/doc/xapian-bindings" ]]; then | ||
mv "${D}/usr/share/doc/xapian-bindings" "${D}/usr/share/doc/${PF}" | ||
fi | ||
|
||
dodoc AUTHORS HACKING NEWS TODO README | ||
} |