Skip to content

Commit

Permalink
games-emulation/dgen-sdl: Fix compiling with clang
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
SoapGentoo committed Jul 5, 2020
1 parent 94cbe7e commit d3f96c9
Show file tree
Hide file tree
Showing 2 changed files with 21 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -24,6 +24,7 @@ BDEPEND="x86? ( dev-lang/nasm )"
PATCHES=(
"${FILESDIR}"/${P}-joystick.patch
"${FILESDIR}"/${P}-AM_PROG_AR.patch
"${FILESDIR}"/${P}-clang-c++11.patch
)

src_prepare() {
Expand Down
20 changes: 20 additions & 0 deletions games-emulation/dgen-sdl/files/dgen-sdl-1.33-clang-c++11.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
--- a/main.cpp
+++ b/main.cpp
@@ -82,7 +82,7 @@
static void help()
{
printf(
- "DGen/SDL v"VER"\n"
+ "DGen/SDL v" VER "\n"
"Usage: dgen [options] [romname [...]]\n\n"
"Where options are:\n"
" -v Print version number and exit.\n"
@@ -256,7 +256,7 @@
{
case 'v':
// Show version and exit
- printf("DGen/SDL version "VER"\n");
+ printf("DGen/SDL version " VER "\n");
return 0;
case 'r':
// Parse another RC file or stdin

0 comments on commit d3f96c9

Please sign in to comment.