Skip to content

Commit

Permalink
dev-games/KXL: port to EAPI 7, eutils--, ltprune--, static-libs--
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Apr 6, 2021
1 parent 5b43a21 commit d42e145
Show file tree
Hide file tree
Showing 5 changed files with 33 additions and 24 deletions.
Original file line number Diff line number Diff line change
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
inherit eutils autotools ltprune
EAPI=7

inherit autotools

DESCRIPTION="Development Library for making games for X"
HOMEPAGE="http://kxl.orz.hm/"
Expand All @@ -11,23 +12,31 @@ SRC_URI="http://kxl.hn.org/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="static-libs"

DEPEND="x11-libs/libX11"
RDEPEND="${DEPEND}"

PATCHES=(
"${FILESDIR}"/${P}-m4.patch
"${FILESDIR}"/${P}-amd64.patch
"${FILESDIR}"/${P}-as-needed.patch
"${FILESDIR}"/${P}-ldflags.patch
)

src_prepare() {
epatch "${FILESDIR}"/${P}-m4.patch \
"${FILESDIR}"/${P}-amd64.patch \
"${FILESDIR}"/${P}-as-needed.patch \
"${FILESDIR}"/${P}-ldflags.patch
default

mv configure.{in,ac} || die

eautoreconf
}

src_configure() {
econf $(use_enable static-libs static)
econf --disable-static
}

src_install() {
default
use static-libs || prune_libtool_files

find "${ED}" -name '*.la' -delete || die
}
16 changes: 8 additions & 8 deletions dev-games/KXL/files/KXL-1.1.7-amd64.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- src/KXLsound.c.old 2007-05-13 21:59:27.000000000 +0200
+++ src/KXLsound.c 2007-05-13 22:09:19.000000000 +0200
--- a/src/KXLsound.c
+++ b/src/KXLsound.c
@@ -4,6 +4,9 @@
#include <sys/ioctl.h>
#include <sys/time.h>
Expand Down Expand Up @@ -42,8 +42,8 @@
// create pipe
if (pipe(KXL_SoundData.Pipe) < 0) {
fprintf(stderr, "KXL error message\npipe error\n");
--- src/KXL.h.old 2007-05-13 22:25:11.000000000 +0200
+++ src/KXL.h 2007-05-13 22:25:47.000000000 +0200
--- a/src/KXL.h
+++ b/src/KXL.h
@@ -205,6 +205,7 @@
KXL_Frame *Frame; // Pointer of frame structure
GC FontGC; // GC of font
Expand All @@ -52,16 +52,16 @@
} KXL_Window;
// RGBE palette
typedef struct {
--- src/KXLimage.c.old 2007-05-13 22:29:02.000000000 +0200
+++ src/KXLimage.c 2007-05-13 22:29:33.000000000 +0200
--- a/src/KXLimage.c
+++ b/src/KXLimage.c
@@ -1,4 +1,5 @@
#include <stdio.h>
+#include <stdlib.h>
#include "KXL.h"

extern KXL_Window *KXL_Root;
--- src/KXLvisual.c.old 2007-05-13 22:22:34.000000000 +0200
+++ src/KXLvisual.c 2007-05-13 22:28:39.000000000 +0200
--- a/src/KXLvisual.c
+++ b/src/KXLvisual.c
@@ -1,4 +1,6 @@
#include <stdio.h>
+#include <stdlib.h>
Expand Down
4 changes: 2 additions & 2 deletions dev-games/KXL/files/KXL-1.1.7-as-needed.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- src/Makefile.am.old 2009-01-28 16:03:27.000000000 +0100
+++ src/Makefile.am 2009-01-28 16:03:47.000000000 +0100
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,3 +2,4 @@
libKXL_la_SOURCES = KXLmisc.c KXLsound.c KXLjoystick.c KXLvisual.c KXLimage.c
include_HEADERS = KXL.h
Expand Down
4 changes: 2 additions & 2 deletions dev-games/KXL/files/KXL-1.1.7-ldflags.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- KXL.m4.old 2010-09-23 14:20:45.000000000 +0200
+++ KXL.m4 2010-09-23 14:21:08.000000000 +0200
--- a/KXL.m4
+++ b/KXL.m4
@@ -29,7 +29,6 @@

dnl add the KXL library
Expand Down
4 changes: 2 additions & 2 deletions dev-games/KXL/files/KXL-1.1.7-m4.patch
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
Get rid of aclocal warning:
/usr/share/aclocal/KXL.m4:6: warning: underquoted definition of AM_PATH_KXL
--- KXL-1.1.7/KXL.m4
+++ KXL-1.1.7/KXL.m4
--- a/KXL.m4
+++ b/KXL.m4
@@ -5,3 +5,3 @@
dnl
-AC_DEFUN(AM_PATH_KXL,
Expand Down

0 comments on commit d42e145

Please sign in to comment.