Skip to content

Commit

Permalink
dev-util/pkgconf: bump to 1.3.5
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5_p31, Repoman-2.3.2_p61
  • Loading branch information
floppym committed May 7, 2017
1 parent 4c1968b commit d47d30b
Show file tree
Hide file tree
Showing 3 changed files with 73 additions and 1 deletion.
1 change: 1 addition & 0 deletions dev-util/pkgconf/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST pkgconf-1.0.1.tar.gz 362653 SHA256 45ce2f6ab032451345185b800badd77c05404087
DIST pkgconf-1.0.2.tar.xz 247972 SHA256 a7c67f8603c0d0400be17b2efac0fdc9ff46625f7e50aefe4ad31eff248115dd SHA512 679c9033489076ba5691c3a830b8e300c6cb2dc9e7eeffa1a478c681c7f1cc49896b0b5d0d069b14804a5c9bc31115ba672b1f724cd6282ce26d54945a5a8a42 WHIRLPOOL e7bcb19eba08ff271a470a1c8bba13810951c20e79b7dea5352ea20b8b519d4462892c623e8383b540f5af3b6daf302386b8b1831bfed3d7d143f33cb9e0830a
DIST pkgconf-1.1.0.tar.xz 264428 SHA256 5f1ef65d73a880fa5e7012102a17f7b32010e5e46139aed85851a541ba828a63 SHA512 2d54b14b9fb830a3d30e8812f6079a95cf1e1e77fd42d1eac7a6041347094ff88b79146be93c56625c44e2dcf38af725cbbdfdda09b457b921a9a17b97a23d15 WHIRLPOOL deffe0277f48f39b3824a25f255da6cdf51bdcf973d9b19f8eb166ba388c6440451d07bf37862f044a4e8be572d4ea5406ff243759fa5f22c0e6ecce8064ba31
DIST pkgconf-1.2.2.tar.xz 267268 SHA256 b445d16df8b6e88489039eb2d7d91d5668025cb058a1852f3e0fdee19c8cb104 SHA512 0d9f74a69bd36f55b1485341127bff08487d5216ae495cea0474e6d23bb323d5c8c7d36b25c2e58282b1bcb0d74da6bb93ee0757e98405aba42b13f2e76eeac2 WHIRLPOOL ef2fe3045b058d627a920e3f2648bbfe2de763bb3f52f61b835684b533cbd768fd0ef892d7c99b89ac73b42d02ba4409d098b285d2943cad6017617112087257
DIST pkgconf-1.3.5.tar.xz 271216 SHA256 886c397b22907209a7483229a8bf473afe151de50527c4b4d04b94fdba0f0c8e SHA512 a937607a5a868f136b1f8018f152512a3c6997e1e73baf7bd9af54c3e5542ecdac2f24df0078df2e0c8544060ba26a25ade88b7949c97ca4fe783d656a1804de WHIRLPOOL 9287c800063cac6ff8124a131e9f99c89112f56f9e14f72f525d97f3041a7444b4b71a64779925f5352a80f7205ae66e30e30ce98a5926dcd9c6ce1c1bb9519f
66 changes: 66 additions & 0 deletions dev-util/pkgconf/pkgconf-1.3.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI=( {https,git}://github.com/pkgconf/${PN}.git )
inherit autotools git-r3
else
SRC_URI="https://distfiles.dereferenced.org/pkgconf/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris"
fi

inherit ltprune multilib-minimal

DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
HOMEPAGE="https://github.com/pkgconf/pkgconf"

LICENSE="BSD-1"
SLOT="0"
IUSE="+pkg-config"

# tests require 'kyua'
RESTRICT="test"

DEPEND=""
RDEPEND="${DEPEND}
pkg-config? (
!dev-util/pkgconfig
!dev-util/pkg-config-lite
!dev-util/pkgconfig-openbsd[pkg-config]
)"

MULTILIB_CHOST_TOOLS=(
/usr/bin/pkgconf
)

src_prepare() {
default

[[ ${PV} == "9999" ]] && eautoreconf
if use pkg-config; then
MULTILIB_CHOST_TOOLS+=(
/usr/bin/pkg-config
)
fi
}

multilib_src_configure() {
ECONF_SOURCE=${S} econf
}

multilib_src_install() {
default

if use pkg-config; then
dosym pkgconf /usr/bin/pkg-config
else
rm "${ED%/}"/usr/share/aclocal/pkg.m4 || die
fi
}

multilib_src_install_all() {
prune_libtool_files
einstalldocs
}
7 changes: 6 additions & 1 deletion dev-util/pkgconf/pkgconf-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -11,7 +11,7 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris"
fi

inherit multilib-minimal
inherit ltprune multilib-minimal

DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
HOMEPAGE="https://github.com/pkgconf/pkgconf"
Expand Down Expand Up @@ -59,3 +59,8 @@ multilib_src_install() {
rm "${ED%/}"/usr/share/aclocal/pkg.m4 || die
fi
}

multilib_src_install_all() {
prune_libtool_files
einstalldocs
}

0 comments on commit d47d30b

Please sign in to comment.