Skip to content

Commit

Permalink
dev-ros/test_rospy: Initial import. Ebuild by me.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.21
  • Loading branch information
aballier committed Sep 22, 2015
1 parent 50a91c1 commit d4867df
Show file tree
Hide file tree
Showing 4 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ros/test_rospy/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST ros_comm-1.11.14.tar.gz 945041 SHA256 8e7beff35711b1918501c69cca4f29648d4d4207878edab069bcd59d515c78f3 SHA512 be768faa0a2f45c464e963934a95dc617cac6c3fcec2388602a27846774c25b882b5139099ce10d1d051a21d5938819942e079836d14618071bc7ad90ee78bab WHIRLPOOL e047ce984086655294c20dbf0715cc29f51ec358f075f02de80c5de0d4ef8059990dc8312d78d7a7fa91c4a974dc21cba15d6eacafe02fd3df527770e50f75a5
5 changes: 5 additions & 0 deletions dev-ros/test_rospy/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>ros</herd>
</pkgmetadata>
34 changes: 34 additions & 0 deletions dev-ros/test_rospy/test_rospy-1.11.14.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

ROS_REPO_URI="https://github.com/ros/ros_comm"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=test/${PN}
CATKIN_HAS_MESSAGES=yes
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"

PYTHON_COMPAT=( python2_7 )

inherit ros-catkin

DESCRIPTION="Unit tests for rospy"
LICENSE="BSD"
SLOT="0"
IUSE=""

RDEPEND=""
DEPEND="${RDEPEND}
dev-ros/rostest[${PYTHON_USEDEP}]
dev-ros/std_msgs[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/test_rosmaster[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/rosunit[${PYTHON_USEDEP}]
test? (
dev-python/numpy[${PYTHON_USEDEP}]
dev-ros/rosbuild
dev-ros/rosgraph[${PYTHON_USEDEP}]
dev-ros/rospy[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
)"
34 changes: 34 additions & 0 deletions dev-ros/test_rospy/test_rospy-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

ROS_REPO_URI="https://github.com/ros/ros_comm"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=test/${PN}
CATKIN_HAS_MESSAGES=yes
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"

PYTHON_COMPAT=( python2_7 )

inherit ros-catkin

DESCRIPTION="Unit tests for rospy"
LICENSE="BSD"
SLOT="0"
IUSE=""

RDEPEND=""
DEPEND="${RDEPEND}
dev-ros/rostest[${PYTHON_USEDEP}]
dev-ros/std_msgs[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/test_rosmaster[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/rosunit[${PYTHON_USEDEP}]
test? (
dev-python/numpy[${PYTHON_USEDEP}]
dev-ros/rosbuild
dev-ros/rosgraph[${PYTHON_USEDEP}]
dev-ros/rospy[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
)"

0 comments on commit d4867df

Please sign in to comment.