forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Azamat H. Hackimov <[email protected]> Closes: gentoo#16529 Signed-off-by: Joonas Niilola <[email protected]>
- Loading branch information
1 parent
72fec15
commit d4aa982
Showing
2 changed files
with
42 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST luasec-0.7.tar.gz 47965 BLAKE2B 5bd19cfb5c2529a6fbee221442730c87394f1bf3d5089dd83d18e91ef1a2b88cde19c59988e438eb37e50c02c40a8906ad11ce9b3247b03ea11ed6d9e890b7d6 SHA512 6adf5241aa5a0d92c9dd7fc7f7e426969475548f47979ccc28187471b3bad4132c215de6da1f471d21b05c6558d36309264512c9c4ac70a53d6f6e204cac1358 | ||
DIST luasec-0.9.tar.gz 52163 BLAKE2B fa95ae63b36f138f923dc412f527ff527e4f7562ad177ca7f450ef889e75c204d1bfec3773523fb68865c3846a0edc583cbf903db5233ff080074147f33bfb30 SHA512 ea601016328232ca0ff12be72897eeedac88a78834a63e1c36d2828a3187039665a2c60597b5af1fa6917b6fe87cd292fbcdfabcd67bab968f587e038d52a933 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,41 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit multilib toolchain-funcs | ||
|
||
DESCRIPTION="Lua binding for OpenSSL library to provide TLS/SSL communication" | ||
HOMEPAGE="https://github.com/brunoos/luasec" | ||
SRC_URI="https://github.com/brunoos/luasec/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
KEYWORDS="~amd64 ~arm ~x86" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
IUSE="libressl" | ||
|
||
RDEPEND=" | ||
>=dev-lang/lua-5.1:0[deprecated] | ||
dev-lua/luasocket | ||
!libressl? ( dev-libs/openssl:0= ) libressl? ( dev-libs/libressl:= )" | ||
DEPEND="${RDEPEND}" | ||
BDEPEND="virtual/pkgconfig" | ||
|
||
src_prepare() { | ||
default | ||
sed -i -e "s/-O2//" src/Makefile || die | ||
lua src/options.lua -g /usr/include/openssl/ssl.h > src/options.c || die | ||
} | ||
|
||
src_compile() { | ||
emake \ | ||
CC="$(tc-getCC)" LD="$(tc-getCC)" LIB_PATH="" \ | ||
linux | ||
} | ||
|
||
src_install() { | ||
emake \ | ||
LUAPATH="${D}/$(pkg-config --variable INSTALL_LMOD lua)" \ | ||
LUACPATH="${D}/$(pkg-config --variable INSTALL_CMOD lua)" \ | ||
install | ||
} |