Skip to content

Commit

Permalink
app-benchmarks/stress-ng: bump to version 0.13.07
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/824118
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed Nov 20, 2021
1 parent 9e4a3c4 commit d4c4014
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-benchmarks/stress-ng/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST stress-ng-0.13.06.tar.gz 1014981 BLAKE2B a93ff571919707568cd0162479e47c6241b4081713cfa88b30594227d01f9af2a6e3ad759ba62f5f5485322d68768ba1ea19087d07281fa1c2b949bcac99f70e SHA512 7aefc794edaa5799f96dd4afe099b747d532e4367bd372b9ed29db03f8276322113509fdd4885500864d292beeb9f407dc3f2ef2a04f92b65f240ee73eb174bb
DIST stress-ng-0.13.07.tar.gz 1020232 BLAKE2B 54d2e01877420f0a9b03f1d2ffc3665b3d06def29f5d1370ca312a0c3a1453cebd5254e00aa0c0bbda1146785c26047d459e1e844bf3d47348f92529e93c029d SHA512 ec8f483c34c35ee9171f65e24614a3d4855d90cdfdc6c2d075ff86a2919e1c774ee5da0601e9e30d1c1f7fa7b146bf877de13e3deb88c892b703eb1b4c41e960
56 changes: 56 additions & 0 deletions app-benchmarks/stress-ng/stress-ng-0.13.07.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit linux-info toolchain-funcs

DESCRIPTION="Stress test for a computer system with various selectable ways"
HOMEPAGE="https://github.com/ColinIanKing/stress-ng"
SRC_URI="https://github.com/ColinIanKing/${PN}/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
IUSE="apparmor sctp"

DEPEND="
dev-libs/libaio
dev-libs/libbsd
dev-libs/libgcrypt:0=
sys-apps/attr
sys-apps/keyutils:=
sys-libs/libcap
sys-libs/zlib
virtual/libcrypt:=
apparmor? (
sys-apps/apparmor-utils
sys-libs/libapparmor
)
sctp? ( net-misc/lksctp-tools )
"

RDEPEND="${DEPEND}"

DOCS=( "README.md" "README.Android" "TODO" "syscalls.txt" )

pkg_pretend() {
if use apparmor; then
CONFIG_CHECK="SECURITY_APPARMOR"
check_extra_config
fi
}

src_compile() {
tc-export CC

export MAN_COMPRESS="0"

local myemakeopts=(
HAVE_APPARMOR="$(usex apparmor 1 0)"
HAVE_LIB_SCTP="$(usex sctp 1 0)"
VERBOSE="1"
)

emake "${myemakeopts[@]}"
}

0 comments on commit d4c4014

Please sign in to comment.