Skip to content

Commit

Permalink
app-cdr/dumpet: add musl fix
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/715450
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Ben Kohler <[email protected]>
  • Loading branch information
benkohler committed Mar 30, 2020
1 parent 2890983 commit d4cca38
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
44 changes: 44 additions & 0 deletions app-cdr/dumpet/dumpet-2.1_p20140601-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit toolchain-funcs vcs-snapshot

COMMIT="8f47670dd582c96ad1b6dd3c9b9da0acebded5d8"

DESCRIPTION="A tool to dump and debug bootable CD-like images"
HOMEPAGE="https://github.com/rhboot/dumpet"
SRC_URI="https://github.com/rhboot/dumpet/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
#Restrict tests since required test file is unavailable
RESTRICT="test"

RDEPEND="dev-libs/libxml2
dev-libs/popt"
DEPEND="${RDEPEND}
virtual/pkgconfig
test? ( dev-util/valgrind )"

PATCHES=( "${FILESDIR}"/musl-byteswap-fix.patch )

src_prepare() {
sed -i Makefile \
-e "s/^install : all$/install :/" \
-e "s/^CFLAGS:=/CFLAGS?=/" \
-e "s/^CC:=/CC?=/" \
|| die
default
}

src_compile() {
emake CFLAGS="${CFLAGS}" dumpet
}

pkg_setup() {
tc-export CC
}
11 changes: 11 additions & 0 deletions app-cdr/dumpet/files/musl-byteswap-fix.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
diff -ur a/applepart.c b/applepart.c
--- a/applepart.c 2020-03-30 10:25:52.122137073 -0500
+++ b/applepart.c 2020-03-30 10:26:09.803672537 -0500
@@ -27,6 +27,7 @@
#include <string.h>
#include <stdio.h>
#include <errno.h>
+#include <byteswap.h>

#include "applepart.h"
#include "endian.h"

0 comments on commit d4cca38

Please sign in to comment.