Skip to content

Commit

Permalink
dev-util/mingw-runtime: Migrate CROSSCOMPILE_OPTS=headers-only -> USE…
Browse files Browse the repository at this point in the history
…=headers-only

CROSSCOMPILE_OPTS is a USE_EXPAND of a single item: headers-only.
Convert it to a global USE flag instead.

Mechanical ebuild rename done as:
    $ sed -e 's@crosscompile_opts_headers-only@headers-only@g' \
        -i $(git grep -l headers-only)

'headers-only' flag is used by crossdev to bootstrap stage1 compiler
before libc is available.

crossdev switched to USE=headers-only in =sys-devel/crossdev-20171230.

Bug: https://bugs.gentoo.org/642712
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
Sergei Trofimovich committed Jan 7, 2018
1 parent 67ec9ae commit d4ea334
Show file tree
Hide file tree
Showing 4 changed files with 12 additions and 12 deletions.
6 changes: 3 additions & 3 deletions dev-util/mingw-runtime/mingw-runtime-3.18.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

export CBUILD=${CBUILD:-${CHOST}}
Expand All @@ -19,7 +19,7 @@ SRC_URI="mirror://sourceforge/mingw/${MY_P}-src.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~ppc ~sparc x86"
IUSE="crosscompile_opts_headers-only"
IUSE="headers-only"
RESTRICT="strip"

S=${WORKDIR}/${MY_P}
Expand All @@ -28,7 +28,7 @@ is_crosscompile() {
[[ ${CHOST} != ${CTARGET} ]]
}
just_headers() {
use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
use headers-only && [[ ${CHOST} != ${CTARGET} ]]
}

pkg_setup() {
Expand Down
6 changes: 3 additions & 3 deletions dev-util/mingw-runtime/mingw-runtime-3.20.2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="4"
Expand All @@ -22,7 +22,7 @@ SRC_URI="mirror://sourceforge/mingw/${MY_P}-src.tar.lzma"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="crosscompile_opts_headers-only"
IUSE="headers-only"
RESTRICT="strip"

DEPEND="app-arch/xz-utils"
Expand All @@ -33,7 +33,7 @@ is_crosscompile() {
[[ ${CHOST} != ${CTARGET} ]]
}
just_headers() {
use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
use headers-only && [[ ${CHOST} != ${CTARGET} ]]
}

pkg_setup() {
Expand Down
6 changes: 3 additions & 3 deletions dev-util/mingw-runtime/mingw-runtime-3.20.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="4"
Expand All @@ -22,7 +22,7 @@ SRC_URI="mirror://sourceforge/mingw/${MY_P}-src.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="crosscompile_opts_headers-only"
IUSE="headers-only"
RESTRICT="strip"

S=${WORKDIR}/${MY_P}
Expand All @@ -31,7 +31,7 @@ is_crosscompile() {
[[ ${CHOST} != ${CTARGET} ]]
}
just_headers() {
use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
use headers-only && [[ ${CHOST} != ${CTARGET} ]]
}

pkg_setup() {
Expand Down
6 changes: 3 additions & 3 deletions dev-util/mingw-runtime/mingw-runtime-4.0.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="4"
Expand All @@ -23,7 +23,7 @@ LICENSE="BSD"
SLOT="0"
# Collides with w32api-4.x
#KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="crosscompile_opts_headers-only"
IUSE="headers-only"
RESTRICT="strip"

DEPEND="app-arch/xz-utils"
Expand All @@ -35,7 +35,7 @@ is_crosscompile() {
[[ ${CHOST} != ${CTARGET} ]]
}
just_headers() {
use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
use headers-only && [[ ${CHOST} != ${CTARGET} ]]
}

pkg_setup() {
Expand Down

0 comments on commit d4ea334

Please sign in to comment.